Black/Blank screen on T95Z PLUS

  1. My device is T95Z PLUS 3/32G
  2. New installation
  3. I used version CoreELEC 9.2.5

I tried all the dtb of Q20x, but the screen is still black after startup.
I connected a USB keyboard, and then I can type on the screen.

what should I do???

If the specs of your box are as below ?
The dtb.imb is there below as well.
No idea what Q20x you’re posting is.

Amlogic S912
1000M LAN

Correct device tree
Rename to dtb.img

I did this

I have tried writing to a USB disk or SD card, but none of them work.
Once I entered the installation interface, but after the automatic restart, it couldn’t start.
After that, it never started successfully.
This is the device information

so you burned an image with windows using balenaEtcher-Portable-1.5.86, or rufus.
After burning the image, you should see a folder devices tree, you then copy the correct device tree to the root & rename to dtb.img. This is done on the pc.

you then plug the sd card into your device, while plugging in the power lead you hold the reset button in, release it after a few seconds,

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.