Black Screen with 8.95.4

A95X 1Gb s905x working Ok. Internal memory with U-Boot and Android 7.1 from Nougat prerelease ROM

I had the same black screen problem after updating to 8.95.4 version on Tanix TX3 Mini installed on internal. Latest build fixed it.
How can I turn on Kodi splash screen? Now it’s all black until Kodi boots up.

Thx for the quick test images, fixed the black screen for me on Akaso HM8 S905X box.

I am now able to boot my A95x (S905X).
I would like to note that there is no splash screen/boot time logo. I used to see the coreelec icon during boot.
Until Kodi starts it is all black.
Not the end of the world, but it is nice to have some kind of feedback that the system is booting.

Thanks to those who tried my test builds. has been released, and is available on the release page.


@wizardknight @ivsha9 Will add the missing boot splash to my list of things to look into.

I have just updated my Tanix TX3 Mini and everything looks fine.
Some more info, until Kodi starts up screen is blank. There is no information on the screen about upgrade process. Not a dealbreaker but it would be nice to have some information what’s going on.
Thank you for your efforts, you’re fast like lightning. :slight_smile:
Keep up the good work.

There is still some stuff to work out, but the intent is to have information about the upgrade process visible.

Just a lot of possible combinations of devices, tv’s, avr, etc… to get it all sorted and tested in one go.
Which is why the occasional oops we tested that but it still broke for some people happens.

16 posts were merged into an existing topic: Black Screen with and 4k TVs

So an interesting tidbit about the splash screen.
I rebooted into android on the internal storage a few times, and then back into the coreelec on my sd card.
The coreelec splash screen started showing up.

I just freshly flashed the official image from git.
So far things are looking good.

Both 8.95.4 and worked on my GooBang Doo M8S-II S905, no black screen. I have no disp_cap file in userdata.

This problem was display related. Not everyone was/is affected by it.

1 Like

I moved everybody that was having problems with the release to a new topic, to be able to better help people still having issues without the clutter of the old problem.

The release solved the black screen bug for users who where using 1080p displays.

Unfortunately it also introduced a new bug for users with 4k displays.

We believe we now have a fix for this as well. However I would like to ask a couple of you that had the original black screen bug to help test the new build before we officially make a release.

Just to make sure that the black screen bug is still fixed for you in the new release, before we release it.

Odroid C2



If requested I can build a test image for the other supported platforms.

now all …4 & 4.1 & 4.2 & rc1 & rc2 = black screen
i want backup from ssh , how i do that ?

Could you also upload this info from last version before going to previous version:

If you are having display problems with the 8.95.4.x releases. There is an updated release that needs testing before we can move on to a 8.95.5 release.

Note: To make sure we get accurate results when testing you should remove any custom disp_cap file and make sure that you have not added anything like echo 422,10bit > /sys/class/amhdmitx/amhdmitx0/attr to your file. Writes to /sys/class/amhdmitx/amhdmitx0/attr can break stuff now (If you don’t know what that is you’re probably ok. :slight_smile: )


strangely after using 9.2.0 on an Amlogic device for months now, today when I stopped a TV channel I got a black screen. Not even a number of restarts helped. Found this thread, tried adding 1080p60hz into the disp_cap file and it seems to have resolved my problem. The TV display is FullHD, no 4K support.

Could this problem still exist in 9.2.0?

Please open a new thread with this issue using 9.2.0
You should notb e having issues with a 1080p TV.
I use a 1080p TV with no issues using TVHeadend Server and client.