Blank/Black screen after the initial splash

Hi All,

I’m having a problem with my new Odroid N2+, which was pre-installed with CoreELEC.

When it works, it works great.

But about 50% of the time, it shows the CoreELEC splash screen, then shows a Kodi opening animation (from the Aeon Nox Silvo theme), but then the screen goes completely black and nothing seems to be able to kick it into action.

A forced reboot will sometimes make it work, but I have done as many at 4 restarts with each one ending up on the blank screen. Very frustrating when the family just want to watch something!!

While in this ‘black’ state, I have tried running “dispinfo” and “dmesg | paste” (via ssh). Here are the outputs, if that’s helpful …

dispinfo

http://ix.io/2EvJ

dmesg | paste

http://ix.io/2EvK

I have no idea what I’m looking for in those. Is there anything useful in there?

My projector is a BenQ W1350, if that matters.

Can I fix this, or is my Odroid N2+ faulty?

Thanks,
Damian

The situation is worse than I thought.

It’s now been over a dozen times that I’ve rebooted and been unable to see the Kodi GUI. I see the CoreELEC splash screen, followed by the Kodi opening animation (from my selected theme), then just a blank screen.

It’s been a couple of days now since I saw the Kodi GUI.

My projector seems to find the correct video mode (it pops up “1080p at 60Hz” in the top left), but there doesn’t seem to be anything that I can do to get the comedy GUI to pop-up.

Do my dispinfo and dmesg outputs (above) help at all?

Is there a way to turn off the Aeon Nox Silvo animation, to see if that changes anything, from either ssh or ftp?

Is this fixable, or do I need to be sending my Odroid back?

Thanks,
Damian

PS The situation may have got worse since I enabled CEC on my Odroid and projector.

However, it was all working fine when I first enabled that. I tried multiple shutdown and restart cycles in testing the CEC, and all seemed fine initially.

What you should do is try a fresh CE install from a uSD without skin changes and such. This way you can see if there’s some problem with your CE install or if the problem is deeper. Try also multiple hdmi cables.

Bizarrely, this was caused by enabling the Aeon Nox Silvo’s theme opening animation.

I have no idea why, but the nice animation would play, and then everything would go black.

Turning the animation back off has fixed everything. I now boot straight into the menus, with no problem.

Hope this can help someone else.

Thanks,
Damian

About | FAQ | Terms of Service | Privacy Policy | Legal Notice