Blank Screen On Older Monitors

Hi, hope someone can point me in the correct direction, tried a few things.

Main issue is; I can’t get anything displayed on GNR TS902W monitor. Works OK on a TV. Was having problems with another old 4:3 monitor (quick test setup), but after setting resolution lower in Kodi that monitor seems to work OK now (but doesn’t display anything during boot).

Device is labelled MQX Pro (not 4K), appears to be Nexbox A95. Worked fine on both monitors with stock android (now doesn’t work at all on GNR TS902W).

Latest dispinfo after trying very low res

Just checked dmesg, getting a bunch of osd_rdma: update_table_item overflow! now (wasn’t before), other lines of interest

[12161.691305@2] codec:vdec_create instance ffffff8003ed9000, total 1
[12161.691660@2] vinfo: error: invalid vinfo. current vmode is not supported
[12165.016331@3] hdmitx: set frac_rate_policy as 0
[12165.016355@3] vout_serve: vmode set to 480p50hz
[12165.016359@3] vout_serve: don't set the same mode as current

Tried a variety of resolutions using a variety of methods. Any suggestions?

I guess a bit niche using older monitors. But it feels wrong getting rid of stuff that’s good enough for specific purposes (e.g. media in kids room during lockdown).

I was surprised I don’t seem able to revert to a working state (coreelec is on SD card).

Just hoping there was something simple I’m missing due to lack of understanding / experience.

Try with 480p60hz