Blocking discovery of Bluetooth devices

Last night I had an almost embarrassing situation develop where I went to connect my bluetooth headphones but just as I was about to click on them in my list of available devices, the list changed and I ended up connecting to my neighbours TV and whilst initially trying to figure out why there was no sound coming from my headphones, what I was playing was being transmitted to the TV.

Thankfully, what I had been watching was not as embarrassing as it could otherwise have been lol

So, armed with only the device name and it’s address, is it possible to permanently exclude a device from being shown as available to pair/connect in CE?

2 Likes

:rofl:
That is so funny, I mean you could have been watching the Wombles or something!!!

Well it seems unlikely because you need to pair devices. Without pairing first the wrong device it can’t just connect. Or did you pair your devices mutually with each other?

It may have happened before that I have clicked one of the devices and it has accepted pairing and on this repeated occasion made the connection but it would be nice to be able to prevent anything like that happening again.

Just unpair it. Autoconnect is something people ask all the time. You can also disable Bluetooth.

Disabling bluetooth will prevent use of those devices that I do want to see and use, so would defeat the object of my desire.

I’m looking at the bluetoothctl command to see what that can potentially do.

Why not unpair the foreign device?

I have.

I am looking to avoid the same issue again in the future.

Not critical but would be useful if there is an option available .

Don’t ask, don’t get.

sorry for bumping this old thread, but i changed my bluetooth setup and workflow with a few new devices. i’ve turned autoconnect off for everything, as i playing the “oh shit what are my headphones connected to” game. not that big of deal with manual BT selection from the coreelec menu (with a shortcut on a remote to take me right to those settings)

however, i have noticed a BT bug where, as the BT devices are discovered and enumerated, if a new device is added to the list after you’ve selected the device you want to pair with (and the menu pops up with the pair, forget, etc. settings), kodi will hang after you select pair and will restart after about 10 sec.

my solution so far has just been to wait about five seconds and let everything be enumerated, but sometimes a rogue BT device will show up and cause this crash.

not a high priority bug. a BT whitelist would be cool, but not sure of the dev time required for that.

luv u, core elec

I have see the locking up and restart scenario many times in the past.

It seems that when 2 Bluetooth processes engage at the same time, things trip up a little.

I have seen the same kind of situation in Windows and Linux, although those 2 operating systems suffer a longer delay to recover instead of restarting.

Like you though, I follow the same solution to wait a few seconds for things to be enumerated and so this is the essential solution.

About | FAQ | Terms of Service | Privacy Policy | Legal Notice