Bluetooth and Wifi worked only once, never more

Hey, there!

I´m using Coreelec on a S905X2 Box, and since the beginning without WIFI or Bluetooth. Today, I´ve changed the SD card used for Coreelec, and I´ve done all installation process again, using the same dtb.img and all others steps just like I always did and for my surprise the Wifi and Bluetooth were working perfectly. I could use my Wifi 5g (my ethernet port is just fast) and the Bluetooth remote that came with the box and everything was working fine.

But then I turned off the box and when I turned on again, the wifi and Bluetooth were gone. I´ve tried to hard reset and do all the processe again, but no sucess.

The thing is, the hardware work. It might be a software / driver problem. Any thoughts how can I fix that? Is that ever happen to someone else??

Thank you, guys! And a happy new year!

I suggest starting with going through the troubleshooting steps.

1 Like

Thanks for your reply. I went to the page you suggested and I´ve generated URL with debug information from the device ( But I can´t reproduce the issue, because now it only shows the wired connections (like there is no wifi adapter) and in Bluetooth tab shows “no bluetooth adapter found”.


And WiFi and BT are enabled in CoreELEC Settings?

1 Like

That´s so weird, after reading your message I turned on the device and went to network tab under Corelec Settings and I could activate or deactivate Wifi Network (BT too) and worked again. Then I restard Kodi and keep working. After I reboot the system and Wifi and BT were gone. Under network tab on Corelec Settings I could´t see wireless network settings (only wired networks), BT was showing again “no bluetooth adapter found”.

But I did one thing when WIFI and BT were working, I created a system and kodi backup (on system tab - coreelec settings). So I restored the backup and everything was working and works perfectly until I reboot the device!

The link to the log isn’t working. Could you generate a new one and post again? Be aware the links are cAsE sEnSiTiVe.

If possible, for comparison, generate a log after you restored the backup and BT and WiFi are working, and one after you reboot and BT and WiFi are no longer working.

1 Like

I didn´t realize it is case sensitive. Well, I tried to restore the backup again today and no sucess. BT and Wifi are not working. I´ve generate a new log now (without BT and Wifi) -
I´ll try to make it work again somehow and generate another log with them working

1 Like

I could get it working again, after a fresh install
I´ve saved 2 log files
One after fresh install (
One after restart kodi (

1 Like

Based on the logs, I’m going to refer you to this thread.

1 Like

Yes, I´ve posted a message there. I´ll take a time to read old messages to see if I can find a solution for my case! Thank you soo much for your time!

1 Like