Bluetooth audio auto connect


#1

Hi,

please, enable feature to automatically connect to a Bluetooth audio when headphones are available. This is the first Bluetooth device that is not able to do that in my life :slight_smile: Would it be possible?

Thank you for understanding


#2

I think you need some better headphones, my Bose QC35 MKII already automatically connect when available.


#3

don’t think … it does not automatically connect and switch audio to bluetooth (as the only device in my life does not do that) even when connected with my 200 EUR headphones, I think its not a fault of my expensive and never problematic head phones :slight_smile:

what settings have you applied?

of course the plugin for that does not work and audio profiles are not so convenient

btw, great work with CE in general!.. cannot live without nowadays … just would make better recording with conditions :slight_smile:


#4

You can use my solution. Mine blog is in Russian, so please use Google Translate. Or just download two files via the link below the article and put them to /storage/.config/udev.rules.d without reading :slight_smile: Fell free to ask me a question here if you’ll get lost.


#5

It would be nice to know if it helped someone :wink:


#6

I’ve been using a toggle script and I’ve had it mapped to some key on the keyboard/remote.
Your script is definitely more convenient, thanks for sharing!


#7

thx my Slavic brother! :slight_smile:
do you think it works independently of a hardware, MeCool KIII?

I think this should be implemented in CE and should work out of the box :slight_smile:

edit: yes, it works, thank you! And now just what to do when MeCool does not auto connect to my headphones (very good ones) automatically?

thx


#8

Iirc there is or was an kodi addon in our repo for this

Edit : there is https://github.com/CoreELEC/CoreELEC/blob/coreelec-9.0/packages/addons/service/bluetooth-audio/package.mk


#9

Thanks, I even had it installed. I thought it didn’t work and used my toggle script instead but now I realized it was incorrectly configured. It has one setting and I had managed to get it wrong. :man_facepalming:


#11

Nice, thank you! I made my script about 1.5 years ago when there wasn’t any other solution, but seems i published it too late :slight_smile: This plugin definitely the much more convenient solution!


#12

whatever works best. It’s nice to have alternatives.


#13

didn’t work for me, just freezed my Kodi all the time

maybe I just configured it wrongly … I use just hdmi and Bluetooth


#15

It’s pretty hard to misconfigure this plugin :slight_smile: It has only one option - “Audio Device”, which should be set to default “ALSA:default”.


#16

so it does not work, freezes my Kodi every time I get into the Bluetooth devices … later will try create the logs