Bluetooth Pairing

Since mid-May, bluetooth pairing seems a bit broken on the AM6b+. It seems that it pairs mostly successfully, but upon reboot the remote is forgotten. I have tried this with the Homatics BR21, Zidoo 12, and the UR-01 remotes with the same result.

Mods, I tried posting this in the Help & Support, but was not allowed to post there.

No, it’s not broken. It’s just not included feature of BT remotes in bluez. The remote goes to suspend after a while and must be paired again on CE.

Android uses a different system bluedroid, I think.

This happens immediately all the time. Pair → Reboot → Remote Forgotten

When I pair the devices I get
bluetoothctl devices
Device D0:1B:1F:73:68:87 B21
Device 00:01:03:05:48:A4 UR01-BLE

However, upon reboot
bluetoothctl devices is empty.

It seems like this shouldn’t be the case.

I ran into bluetooth issues when the main install was on emmc and booted from usb. After connecting a bluetooth device on the usb install, the bluetooth on emmc was completely screwed.


You gave me an idea because my error started when I booted into the eemc from the USB. So I did a hard reset and the error disappeared. For some reason, it seems that this caused an error. Even when I do a restore from backup the error reappears.