Booting only from SD

Hello,

after update my box - Alfawise S95 (S905W) - not booting, I can boot only from USB.

tried USB Burning tool and got these errors :

[14:03:18 300][HUB4-3][Err]–ResetDevEx ret=-5 error_msg=libusb0-dll:err [reset_ex] could not reset device, win error: A device attached to the system is not functioning.

[14:03:28 456][HUB4-3][Err]–[0x32030201]Uboot/Get result/DiskInitial error

but I can boot CE from USB - is there any way how to fix this ?

Thanks

The following method should work with your original device firmware.

Thanks for reply, actually I have problem find FW with u-boot.bin file. I just found only one img file or ZIP file with boot.img, recovery.img … etc … the device is exactly same as Tanix TX3 mini.

Thanks

Thats good news, glad to hear you got it working again.

Hello Adam,

Do you know of any Linux similar utility that can do this? I sure would like to recover my MX Pro S905 device. However, I don’t have a Windows computer.

There is some instructions below for linux but its not for the faint hearted.

No its not. I have sutcked here

@argento as I said previously, you need the original firmware for your device (img format).

I found one - original. But I dont know, how can be used, tried USB burning tool -

[20:17:21 910][HUB4-4][Inf]-------------ERASE FLASH-----------
[20:17:21 910][HUB4-4][Inf]–disk_initial 1
[20:17:21 910][HUB4-4][Inf]–Send command success
[20:17:22 136][HUB4-4][Err]–failed:[20:17:22 136][HUB4-4][Err]–Check command return failed
[20:17:22 143][HUB4-4][Err]–[0x32030201]Uboot/Get result/DiskInitial error
[20:17:22 143][HUB4-4][Inf]–Close device handle 0x00000864

Try creating a magic sd card with the guide I posted previously.

Yes, I tried, but I used u-boot.bin attached BootcardMaker. For my device i have just one .img file as a firmware.

Adamg,

That’s what I’ve been looking for. Hopefully, it will help to recover my MXQ-Pro S905. Now, I need to look for the original MXQ-Pro S905 firmware. If you know where I can download the original IMG firmware for an MXQ-Pro S905, that will be great. Thank you.

Have a look on geekbuying blog or chinagadgetreviews, they have quite a lot on both those sites.

@argento the u-boot is in the img included. Just use the Amlogic Burn Card maker and create a recovery SD card. It will flash u-boot and system.

Hello,

thanks for replies, I already downloaded Amlogic Tools - and there is one tool for customization - so I found the files… also know how to use Burn Card Maker - extracted those 3 files on sd -

aml_sdc_burn.UBOOT
aml_sdc_burn.ini
S95FW.img

But nothing helped… my box is still dead, black screen. I can boow CE from SD - is there any way to fix the internal storage through this OS ?

Thanks for your time folks!