Browsing NFS servers not working

I have several NFS servers on my local network, however when I go to add a new source browsing for NFS servers doesn’t seem to work anymore. Ha anyone else noticed this behavior?

Worked just fine for me last night, latest nightly.

I did have a box screw up browsing an nfs share once after installing a bunch of addons though.

Im simply running 9.2.1

Strange. Not made any change to the kodi box or the server?

What hardware are you using?

No changes, I have a Ubuntu & CentOS NFS servers, 905X & 905W boxes running 9.2.1 dont see anything when browsing. I already have 4 mount points from the Ubuntu server mounted and they are working perfectly on 3 kodi boxes on the network, so NFS is working just fine. Its just adding a new mount point that the NFS browser doesn’t find any servers. I’ll try & reboot my 2 NFS servers this weekend & see if that changes anything.

I rebooted my Ubuntu & CentOS NFS servers, flashed a new 9.2.1 image on a Amlogic 905W 2Gigs RAM box. I can mount NFS shares from both servers on my Linux laptop, so NFS is working correctly from both servers, just in the browser NFS from the Ubuntu server is not appearing, only the CentOS server NFS shares. Nothing has changed on either server when it comes to the configuration of exporting NFS filesystems.

/etc/exports:
/MOVIES *(ro,insecure,sync,no_subtree_check)

Been working like that for years.

From the CentOS server showmount reports all the available mountpoints from the Ubuntu server.

[root@centos7-1 Downloads]# showmount -e 192.168.100.241
Export list for 192.168.100.241:
/MOVIES *
/disk1/TV/Sylvia *
/disk1/TV/Slynch *
/disk1/TV/Andrew *

Not sure what other info I can give. The Ubuntu server is running 19.10.

I had to add in the mount points as individual sources, then it worked. Browsing Ubuntu NFS servers is not working with 9.2.1 nor with the latest nightly.