Buffering with 2160p remux file's

I Having a buffering issue when trying to play 2160p remux hevc file’s from local hard drive (USB 3.0). About 60gb for a each file.
The movie stop after 5 min to buffer and goes again and again.
Tried with 2 devices:
Mini m8s II - S905x 2gb ram 16gb rom
Ki pro - S905D 2gb ram 16gb rom
Same result.
Even changed the buffer size to 500mb with ares addon and still no changes.

Please help.

The devs could help you better if you mention what build of CE are you experiencing this issue with?

And also logs. No logs, no problem.

1 Like

Both your boxes probably have USB 2.0 ports. So if the data rate exceeds like 30-35 MBps, itll choke. I have a s912 box, usb 3.0 external drive and the max data rate is around 30-35.

30MB/s = 240Mbps.
No remux file reaches that bitrate because the 4K BD standard has a maximum bitrate of 128Mbps. So USB 2.0 is not a problem.

Using the last build: CoreELEC 8.90.4.
And you right 60gb for 120 min, is about 10mb/s so no way it’s the usb 2.0 problem.

See above quote ^^^^

Please provide a sample of the file so we can try to reproduce this, thanks.

1 Like

We allways need debug log video and a/v timing specific logging. It look like you tried play 60Hz movies at 30Hz.

@TheCoolest @anon88919003 @afl1
I would appreciate your assistance

I intsalled the latest version 8.95.1 (clean install - not an update) , and thought the dynamic buffer detection would solve the problem. so I made some tests:

  • the movies I checked are at a refresh rate of 23.976
  • All tests were performed on a local hard drive (USB 3.0 - WD my passport )
  • I tested the file’s on fullhd screen, but the buffering phenomenon also happens on 4K screen
  1. auto refrash rate set to always, default refrash rate set to 50fps.
    here is the log file:
    buffering takes place at these times:

  2. auto refrash rate set to always, default refrash rate set to 23.98fps (The closest to the movie’s refresh rate)
    here is the log file:
    buffering takes place at these times:

  3. auto refrash rate set to always, default refrash rate set to 23.98fps, log includes the component specific logging for audio and/or video (I ran the test for a short time because of file size)
    here is the log file:

  4. I took samples from the movies with MKVToolNix:

Thanks in advance

Okay problem solved. Checked with usb 3 DOK and everything worked great. The hard drive probably did not get enough current.