Bug cover - invisible

I have been using the latest stable CE version for weeks and everything was fine until today. Recently added films no longer display their covers. However, it is well recognized, the information is displayed very well, except for the covers which remain invisible. do you know this problem?

What is amazing is that I did not change any settings. This problem appeared as if by magic.

Which movie scraper are you using?

Sometimes there may be a temporary issue with a service that prevents the artwork from showing or being downloaded.

1 Like

Same for me on a s905x3 32/4gb 1GBit box, latest release, clean install.
Tried both stable and nightly. Booting from stick and emmc.
Scraper were TMDb and Universal Movie Scraper. No pictures.
I tried to restore a full backup (coreelec+kodi) from the “old” s905x installation, but no pictures.
Same for the restore of the kodi db backup.

Non -ng- release on a s905x works without problems.

Check this:

It looks like cloudflare made some changes to their network (more detailed info in the links i gave you) and broke some thinks in kodi. Kodi for Windows is the only not afected.

it also affect another services like IPTV Simple Client:

I have just added some content to Kodi on an X86 machine using the movie database and the artwork is not coming through, so it must the movie database that has an issue, as they ddid not so long back.

Same issue here.

The real issue here is that once it fails to scrape them on the first pass - it never updates the “broken” image so it remains blank for ever.


You can use the menu button on the movie. Choose information -> refresh and when it asks to use the local information says “No”. Then it will look up the information, if it’s there, and you can choose the art.

If the missing information is on their end, then that trick won’t work until it’s fixed.

The issue is fixed. You need at least the version 3.2.5 of the common.themoviedb.org scraper add-on.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.