BUG - Left audio channel only with Sony Wireless Gold Headset

Build: CoreELEC 8.90.5
Device: X96

Steps to reproduce:

1., Connect Sony Wireless Stereo Headset 2.0 to device using USB dongle
2., Switch on Headset
3., Select ‘ALSA Wireless Stereo Headset, Analog’ as Audio output device in Kodi system settings
4., Playback some content (in this case video streaming)
5., Result: Audio only on left channel

Had the same problem in LibreELEC, the last working version of that was, since then the problem occures.
Back then kszaq tought it was related to this: AESinkALSA: Return false if we don’t know about our output channels by fritsch · Pull Request #12641 · xbmc/xbmc · GitHub
See the full post.

LOG file: log file

Thank you for your help!

I went over the code.
This doesn’t look like a CE issue, and doesn’t look like it’s related to that particular change.
it’s a defect in the way Kodi maps channels. If you have a Raspberry Pi, I suggest you try this on it with LibreELEC and see if this problem is still there or not.

Thank you so much for looking into it, I don’t have a Pi, if that matters the headset works perfectly on a Mac - Kodi v17.6. So you think I should try get help from the official Kodi forums?

In every OS Kodi uses a different module for audio. If you don’t have an rPi, I would try LE on a PC, I don’t know whether it works on MAC or not.
In LE, make sure you select the headset with ALSA, as that is the module used in LE/CE on ARM, and see how it goes.
I think you should ask on Kodi forum, but make sure that you can reproduce the problem on another platform first, which Kodi “officially” supports, such as rpi, x86.

Works perfectly on official LibreELEC on PC, also normal Kodi (PC and on Mac installation too). We have an other Amlogic S905X device in the house (same chip as mine) there it won’t work, just like on mine. I think it isn’t a Kodi problem, I can’t figure it out.

Is LE on PC using ALSA or something else? You can look in the logs.

Yeah, LE on PC using ALSA, created a log file, here. Thanks!

After taking a second look at your original logs, it seems that Pulseaudio is used in CE, not ALSA.
Not sure what the issue with that one is, but I can’t see anything useful in the logs from it.

I tried all the settings in the Audio, turning things on and off, changing channel, etc. Maybe that’s when I did the log so it showed I’m using Pulse instead of ALSA. Thanks for your time anyways, sorry you couldn’t help me, looks like I’m staying on that old LE for a while haha.

It’s interesting why it doesn’t work. A full log, with ALSA may be useful, but to be honest, I think the only reasonable way to get this issue fixed is if a dev had a device with an identical issue.

Log file

By the way, if you can see more USB devices it’s because of the original remote is not working with it and I’m using an other one (works on LE).

I have added some info and workaround here , in case anyone still is looking for the information. I came across this post when I ran into same issue recently.

Apologies for replying to a year old thread.