C4: SPI bus and 9.2.5 release?

Is there a difference in the treat of the SPI-related kernel modules (spidev, spi_meson_spicc) in CoreELEC 9.2.5 versus 9.2.4.2 (on an Odroid C4)?

I ask since, after upgrading, no /dev/spi* device files appear to exist. I don’t recall having to do anything special – /dev/spi* was already populated.

Thanks,
Matt

Trying to re-enable SPI via the instructions toward the end of this thread:

https://discourse.coreelec.org/t/spidev-coreelec-9-2-2/11178/9

mount -o remount,rw /flash
fdtput -t s /flash/dtb.img /soc/cbus@ffd00000/spi@13000/spidev@0 status "okay"
fdtput -t s /flash/dtb.img /soc/cbus@ffd00000/spi@13000 status "okay"
echo "spidev" >> /storage/.config/modules-load.d/spi.conf
echo "spi-meson-spicc" >> /storage/.config/modules-load.d/spi.conf
reboot

UPDATE: The above worked nicely. I already had the spi.conf file, as I tried that first; I was missing enabling the relevant entries in the Device Tree.

The /flash/dtb.img is overwritten on update, all user adjustments are lost.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.

About | FAQ | Terms of Service | Privacy Policy | Legal Notice