Cannot boot coreelec on Minix U22-XJ Max

New installation. The box will simply not boot off of the installation media I’ve made. I never get to a CoreElec logo. Mostly I just get boot loops, sometimes freeze on black screen or on the Minix Android logo.

These are the image files I’ve downloaded and made media from.

CoreELEC-Amlogic-ng.arm-19.5-Matrix_rc1-Generic.img
CoreELEC-Amlogic-ng.arm-19.5-Matrix_rc2-Generic.img

I tried making the installation media with balenaetcher on Ubuntu and with Rufus on Windows. Same results.

This is the device tree file I use and rename to dtb.img (and yes, I put it in the same folder as the one that kernel.img is in):

g12b_s922x_minix_u22xj_max.dtb

(There is also a _rev_a version of this file - am I supposed to use that? Only thing I haven’t tried. Nothing on my Minix’s packaging indicates I have “Rev A”.)

I’ve tried using an sdcard in the TF slot, the same sdcard in an sdcard reader plugged into a USB port, AND a regular usb flash drive. All yield similar results with minor variations.

sdcard used: SanDisk 32GB Extreme PRO microSDHC UHS-I/U3 Class 10 Memory Card with Adapter, Speed Up to 95MB/s (SDSDQXP-032G-G46A)

usb flash drive used: Microcenter 32gb

I tried with the MCU setting that turns the Minix box on when power cord is plugged in both off and on. Made no difference (first attempt, it was not turned on and I had to press power button to make it start)

Of the various methods listed to attempt to boot,

  1. “Reset Button” When using sdcard, it usually boot cycles a few times (minix logo - no signal - minix logo - no signal - ad nauseaum) and usually eventually a permanent black screen or freeze on the Minix logo. When using usb flash, it goes to the text recovery options. “Reboot to bootloader” from there doesn’t work, a boot cycle or two and then it goes into android.
  2. “Power Button” option - Does nothing.
  3. “Android APK” - the “Reboot to Libreelec” app does nothing (just dims the screen a bit when I hit “ok” to confirm to reboot)
  4. "Recovery 02 - I tried using the preinstalled android Update app and picked a random .zip, did nothing and eventually booted to Android
  5. “Update” - I could not try this because there is no “Local Update” option under Settings → About This Device.

Important, as I don’t think this is expected behavior: If I have ANY of the installation media plugged in when booting, regardless of whether I’m pressing the reset button, regardless of whether I unplugged power before the boot, the Minix box will not boot at all, not even to Android. Same results - boot cycles and eventual black screen or freeze on the Minix logo. I can only boot Android if I do not have the sd card or usb flash inserted by any method. HOWEVER, if I insert the sdcard after Android has come up, it does recognize the card, and I can move and rename the files on the sdcard within Android’s X-plore with no issues.

The only exception to the above about the reset button doing nothing is, if I am using just the USB flash drive, and I am doing the reset button thing, then I do get to the text recovery options rather than a boot loop/freeze. That’s the only time when pressing the reset button during boot makes anything behave differently.

Through all of these attempts I’ve had an internet friend who owns the same box try to help me through it and advise, but we’re both completely out of ideas to try.

Please halp! Hopefully you can tell how hard I’ve worked the problem on my own before coming here for help. I hope somewhere in all that information there is a clue as to what’s wrong, but please ask away if I’ve left something out.

Revision A indicates SoC version. And I just tried my device with 19.5 rc2 and it works as it should.
Try the other dtb if there is a difference. I assume Android boots ok?

And maybe it’s not a max, try the other minix dtbs as well… My max do work with rc2 as well.

What is “SoC” version please? And yeah, I’ll go ahead and try it.

It is definitely a Max. If it’s not a Max, I was robbed.

It woiked! The Rev A version worked! Woohoo! My long nightmare is over!

Still curious what “SoC” version means, seeing as how it looks like I have one.

It’s a bug in the bootloader introduced by Amlogic. It is not possible to combine the dtbs to a multiDTB because the bootloader try to decrypt the multiDTB what is not encrypted. This all happen only on devices with Dolby Vision support.

So just so I understand, is the “Rev A” dtb a workaround for that problem?

Either way, I’ve got coreelec installed now and it’s working as advertised. Very happy now. Thanks for the help to everyone.