Cannot shutdown my box (it just reboots)

Hi!

Since the nightly 20190115 I cannot shutdown my box (Tanix TX92 with S912) anymore - it just reboots. No matter if I use the hardware button on the box, the menu item within Kodi or turning it off via my mobile phone remote app… it just reboots.

Any idea?

1 Like

Can you paste output of lsmod.

CoreELEC (official): nightly_20190118 (S912.arm)
CoreELEC:~ # lsmod
Module Size Used by
bnep 13847 2
hci_uart 30134 1
bluetooth 340354 23 bnep,hci_uart
6lowpan_iphc 10183 1 bluetooth
8021q 19039 0
wlan 3454532 0
cfg80211 374882 1 wlan
ir_lirc_codec 4996 0
lirc_dev 11232 1 ir_lirc_codec
ir_mce_kbd_decoder 4796 0
ir_sanyo_decoder 2899 0
ir_sony_decoder 2417 0
ir_jvc_decoder 2511 0
ir_rc6_decoder 3423 0
ir_rc5_decoder 2439 0
ir_nec_decoder 3367 0
openvfd 144963 1
mali_kbase 379189 3
meson_ir 4021 0
rc_core 17268 11 lirc_dev,meson_ir,ir_lirc_codec,ir_rc5_decoder, ir_nec_decoder,ir_sony_decoder,ir_mce_kbd_decoder,ir_jvc_decoder,ir_rc6_decoder, ir_sanyo_decoder
wifi_dummy 806 0
amlvideodri 12066 0
videobuf_res 5322 1 amlvideodri
videobuf_core 16549 2 amlvideodri,videobuf_res
videodev 131761 1 amlvideodri
dwc_otg 233217 0
fbcon 38031 0
bitblit 4468 1 fbcon
softcursor 1168 1 bitblit
font 7327 1 fbcon

Here it is… I just tried the “shutdown” command via putty, same result: Instant reboot :neutral_face:

As I thought, you have the qca9377 chipset, we are aware of this issue, since changing the firmware to fix bluetooth on other devices, it is causing some devices to be unable to power off and instead reboot.

Ok, anything I can do?

Try from a terminal

shutdown now -h

to see if it would make any difference.

@Senseohasser nothing yet, as I said the team is aware of it and we are looking into it.

Does not work either :neutral_face:

Same behaviour here after upgrading from 9.1.2 --> 9.2.2 and 9.2.3. an my Khadas Vim3L

Vim3L. same behaviour with 9.2.4.2. no matter what Android is flashed in eMMC

Also tried with CoreElec in eMMC – cannot shut down! :angry:

Can you please open a new thread as you have an SBC that will work with power on and off with CE.
We need to know what you have setup with remote.
Have you injected bl301 and remote Khadas in CE settings

Sorry for the late reply:
regarding your questions:

  • no bl301 injected
  • dont know what you mean @khadas remote
  • It all started after flashing: [VIM3_Pie_V200320] or [VIM3_Pie_V200624]
    { https://docs.khadas.com/vim3/FirmwareAndroid.html }
    –> prior to this I just had: [VIM3L_Pie_V191011] which was able to shut down properly

After the appropriate answer regarding the abov 2 questions, I will open a new thred

CoreELEC settings addon

Navigate to Hardware

Choose Remote and click on Khadas

Inject bl301 and follow prompts.

Reboot.

If you flash another Android Rom in future
You will have to repeat the above.

About | FAQ | Terms of Service | Privacy Policy | Legal Notice