Cannot view / edit sd card contents in windows 10

anyone else here having thsi problem

at the stage after writing the coreelec img to the sd car and needing to adjust the device tree files - windows will no longer let me see teh content of the SD after its written

just gives the usual - device needs to be formatted message
what’s odd is that i am sure up until a few weeks ago ( the last time i did this ) it would display this message - but still allow the sd card to be accessed and edited

is thsi just me - or is it some kind of windows update changing windows behaviour

rufus can still detect the drive and allow me to write to it - and device manager can still see it and says its working normally - but it is no longer in the list of drives in windows explorer

system info below

OS Name Microsoft Windows 10 Pro
Version 10.0.19044 Build 19044

is there a fix/workaround

its a PITA as i am having to edit the sd card in an ancient windows XP laptop i only keep to talk to the computer in the car

Unplug SD card and plug it back in?

yep - tried that many times

for a while it seemed to recognise it if i plugged the USB sd card reader into a different USB port than the one i burned it in - but i have now run out of new ones the card has not been in before - so none of them seem to recognise it


Did you reboot the Windows lately?

Also try to format SD card with SD Memory Card Formatter.

yep tried rebooting windows - no change

i can format the sd card - and see it again - the card is fine
but once i burn a coreelec img to it windows will not show it anymore - so i cannot edit the dtb etc

Just for a test try to unpack .img.gz to .img and write that one. You are using Rufus?

thansk for the help

actually i always unpack the .gz to img before burning it to the SD

the burn part goes fine - its just the odd behaviour in windows i cant get my head around

when i put the SD card into an old XP laptop it can see the coreelec files just fine - and i can edit them there - odd

I think Rufus knows to burn .img.gz directly. Should check…

But I just remember something. After you burn the card open Computer management and then from it Disk management. And check if you see drive (SD card) with 2 partitions but without drive letter on first one. If only drive letter is missing manually add it.

Try to burn your uSD card with Balena “Etcher”. I had similar problems on Win 10 with Rufus, so I use it just to sometimes format uSD cards…

OK i tried etcher - and the reults were different - but still a bit odd

this time after writing the img file to the sd the PC still reported the card needed reformatting and would not let me view the contents

but when i changed the USB socket it was plugged into - it now did allow access and editing of contents ( something it would not do when i used rufus to write the sd card )

odd - but i guess it shows that its a rufus related issue

thanks for your help

No, it´s Microsoft Windows related issue.
I wrote image file >100 times using Rufus, Etcher or win32 disk manager
It is best to do without windows and use linux

There was one recent version of Rufus that did have a problem but v3.18 works.

Sometimes when one USB port works, where another one doesn’t, it can the result of a poor driver as you may have more than one USB controller in your machine, one of which needs a driver update.

It is enough to remove uSD card, after burning with Etcher, and plug it back in for Windows to recognise it. No need to change USB socket…

thanks - i was using 3.17 i think - latest at the time i thought - have 3.18 now so will give that a go at some point

what i mean was the different behaviour between rufus and Etcher was a rufus issue - as both on windows 10

noted - thanks

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.