Can't boot on MXQ Pro 4k

This is a follow up to this topic (unfortunately a new user cannot have more than 3 replies on the same topic).

Can’t boot into CE. Tried both the toothpick method and “reboot to libreelec.apk”, on both SD, and USB.
I tried the slowemmc dtb on all 4 USB ports and SD. No luck…
Really appreciate the help so far. Any other ideas?

If the reset button doesn’t work, you could try

I would have thought the reboot to libreelec would only work, if LE (CE) was already installed.

Thanks. reboot to libreelect simply does a reboot update so it’s supposed to be equivalent.

The only way I could get it to boot was to use the dtb I mentioned and by typing reboot update into terminal.

I own the same box, there are 2 methods, first method is to install terminal emulator on Android, type su, reboot update. Second method is to hold recovery button and connect power - recovery button is located inside audio connector.

To boot sd card id recommended, I tried a few dtb included and I got one of them working (not remember which one)

My MXQ Pro 4k takes the gxbb_p201 file. It’s an S905, not an S905X.

1 Like

Strange, mines a 905x


@JimS thanks. Just tried this dtb and still no luck. I do know that there are several version of this box. Is there a way to figure out which board I have using the installed Android version?

@giaur500 thanks. I tried the recovery button (i.e. toothpick method), and all I got was an “erasing” screen followed by the regular android. As for the terminal emulator - as mentioned above, it’s equivalent to “reboot to libreelec”.

Any other ideas? Keep in mind I might not be able to add additional replies to this thread. If this happens, I’ll try to edit this reply instead.

It may be equivalent, but you’re not even trying it.
Give it a shot, in the worst case it won’t work.

Are you using Rufus to burn the SD/USB cards?

I have an idea worth trying: Boot into stock android and in apps menu launch CPU-Z app. If it’s not there try installing it from appstore.
The app shows you which SoC you have.

I read that there are many fake MXQ Pro 4K boxes with a cheaper Rockchip SoC instead of Amlogic S905X. Maybe you got one of those.

I think you did not burn image to sdcard correctly. So your sdcard is not even bootable. In this case, sdcard is ignored and android recovery starts and it starts erasing /data partition.

With wrong dtb you will end with black screen. Btw. Indeed make sure your box is not Rockchip. It looks the same, not even possible to notice any differdnce in look. I bought the one on Rockchip and returned to seller finally.

Wow, you’re right - it’s a Rockhip RK3066. Would have been pissed at this point, but I basically got this box for free. So I guess, I need LE, and not CE? (and no 4K, right?)

@TheCoolest it’s not that I didn’t want to try, it’s that I’m looking at cost/benefit. Trying this out means trying several dtbs, with 5 different ports (4 USBs and one SD). That’s a lot of time spent, for something that has the same stated behavior. I’d rather spend my debugging time on other directions (such as cpu-z, which indeed seemed to have solved the mystery)

I don’t think there is any LE with your RK3066

Well, I guess this box goes in the trash. Good thing I got it for free

You could search a better working rom for the box over here:

then install FTMC and see what you get.
It’s worth a try.

Thanks. Probably not worth the effort for a box that doesn’t even support 4k

Just look for Mxq on Amlogic. I had the same, Rockchip returned to seller and I got full refund. Then bought from other seller.

I’m actually looking for something that can do HDR as well, and MXQ seems to sometimes be s905, rather than s905x.
In any case, I got this box for free (or more correctly, got refunded for it even prior to this thread), so this one just goes in the trash.