Can't connect to wifi using WPA2. Mecool KM3

When I try to do it with no wifi encryption I can connect (no issues) but when I enable WPA2 encryption and enter the password (the password is correct) it does nothing. No connection then.

What can I do? Need some help, please.

Your router is not allowing access.
What router are you using ??

I’ve got configured my Smart TV, iPhone, and computer without any special router setting, just entering the WPA2 password and working.

Maybe special characters in your WPA2 password are making problems. Try setting a new WPA2 password on your router using letters and numbers without any special characters.

All printable ASCII characters should be accepted in a passphrase according to the IEEE 802.11i‑2004 standard. Here are the allowed characters:


Of which the special characters are:


Space is also a valid character.

However, there seems to be something weird going on in the GUI, since it will give an “Invalid arguments” error when trying to connect to an access point with e.g. a passphrase like this:


This should be a perfectly valid passphrase, so I tried to connect via connmanctl:

connmanctl> agent on
Agent registered
connmanctl> scan wifi
Scan completed for wifi
connmanctl> services
*AO Wired                ethernet_001e06422b23_cable
    network_ap      wifi_200db033d617_e382a2e382a4e382abe38384efbc81_managed_psk
connmanctl> connect wifi_200db033d617_e382a2e382a4e382abe38384efbc81_managed_psk
Agent RequestInput wifi_200db033d617_e382a2e382a4e382abe38384efbc81_managed_psk
  Passphrase = [ Type=psk, Requirement=mandatory ]
  PreviousPassphrase = [ Type=psk, Requirement=informational, Value=memesaregood1 ]
Passphrase? PTSTLqWea@U&QDe8xU9$Vkaay69z&GPV!si$4#HYcw%9fKh%Yy4UyA2Ckfhb3Hh
Connected wifi_200db033d617_e382a2e382a4e382abe38384efbc81_managed_psk

Works great. So the bug is definitely in CoreELEC’s GUI settings. I couldn’t find an existing bug report of this, maybe I’ll make one later.