Can't get Airplay to work

I can’t use Airplay to play sound to Kodi (CoreElec 9.0.3 on ODROID C2) with my Mac (macOS 14.5) or iPhone (iOS 12.3).

The Mac or phone will show Kodi and let me select it as output device but when I try to play any sound I only get an error message :frowning: I don’t see any message in the kodi.log with debug switched on.

Is there anything else I can try to debug?

I faced the same problem after upgrading to (presumably) 9.03
It worked before that.

Interesting. I had Airplay working sometimes in the past on different versions of Kodi on different hardware so I was not able to say when it stopped working and what it correlated with…

Doing some tests… Airplay works with a fresh install of 9.0.1.

…and it stops working after the automatic update to 9.0.3.

After trying also with 9.0.2 which didn’t work in the beginning but started working after I switched Airplay off an on a couple of times it also started working on 9.0.3 :slight_smile: :100:

The best way seems to be to switch off Aiplay in Kodi, wait until it vanishes in the Airplay device list and then switch it back on. Now it works :woman_shrugging:

1 Like

It does require quite a lot of off-on switching now but I could always get it to work so far…

It seem not work anymore for above iOS12 device with airplay,while airtunes dose work all the time.
but if your app support DLNA ,like NPlayer ,it can post your video to screen too.
Hope CoreElec can support iOS new version soon.

It´s impossible to support apple airplay in free software.
You have to ask apple - good luck :innocent:

Airplay for audio still works for me in iOS 13 and MacOS 10.14.

I guess it’s Airplay 1 and I haven’t heard about any open source Airplay 2 support.

Airplay for video or screen sharing hasn’t worked for a long time…

I am on nightly build and the issue is still there

Read two posts above yours.

Well, with all respect, it’s not an Apple issue, and it’s not a Kodi issue. It’s CoreElec one, because it works in other Kodi installation, and stopped worrking in CoreElec
Obviously, you are not obliged to fix it, as you are not obliged to work on CoreElec at all, but pls. don’t shift the focus
If you don’t know how to fix it, or don’t want to fix it, just say so, without pointing fingers to Apple