Can't SSH on 9.2.7

I have two CoreElec devices (a X96 Air, and X88 King). I updated both from v9.2.6 to v9.2.7 when the update came out today.

I have now just tried to SSH into them (tried one, then the other) and both are now giving me this SSH login error:

Received disconnect from 192.168.0.16 port 22:2: Too many authentication failures
Disconnected from 192.168.0.16 port 22

There were no authentication failures before this attempt.

To try to fix it, I’ve gone into coreelec settings via the GUI and reset all of the SSH settings to defaults, and reset the password. But still getting exactly the same error (doesn’t even ask me for my password) on both devices.

Ok, I’ve worked out the problem. Its not related to 9.2.7 or the update that I did.

The problem is: today I am SSHing in from my laptop instead of my desktop PC. My laptop has lots of SSH identity files in the ~/.ssh/ directory and by default the SSH client seems to try to use them all before moving on to ask for the password. But before it gets to that point, the device decides there’s been too many identity attempts and raises that error as above.

To fix it, force it to skip pubkey auth steps, allow password auth, and prefer password auth:

ssh -o PasswordAuthentication=yes -o PreferredAuthentications=keyboard-interactive,password -o PubkeyAuthentication=no root@192.168.0.16

Working fine now.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.

About | FAQ | Terms of Service | Privacy Policy | Legal Notice