CE 8.99.2 on gxbb_p201_2G doesn't boot

#1

Hi

My Sunvell T95 2G/8G is not booting any more after the update to the new version of CE.
My board is the gxbb_p201_2G and CE 8.95.7 worked perfectly.

I’ve tried to copy manually the correct dtb file (gxbb_p201_2G.dtb) without any luck.

Any ideas?

Thanks for your work, it’s amazing!

#2

The “Sunvell T95” (without any T/N/MAX/whatever) is using an S905X SoC (at least according to Gearbest).
Therefore the right dtb would be “gxl_p212_2g”.

#3

No, my model is this one:

https://go.skimresources.com/?id=47674X1192624&xs=1&isjs=1&url=http%3A%2F%2Fwww.gearbest.com%2Ftv-box-mini-pc%2Fpp_268277.html&xguid=71ba62671770783b834005a1c5af9e4d&xuuid=d918f4e373e8f9401af2a0eb40d1d7a8&xsessid=&xcreo=0&xed=0&sref=https%3A%2F%2Fandroidpc.es%2Freview-sunvell-t95%2F&pref=https%3A%2F%2Fwww.google.es%2F&xtz=-60&jv=13.12.3-stackpath&bv=2.5.1

#4

When I open your link, I’m getting the one with the specs from the screenshot below.
Maybe it’s a wrong redirect (Gearbest always seems to redirect to local websites), but here it is clearly S905X (with 1GB RAM).

#5

Do you have a working 8.95.7 with that dtb right now?
cat /proc/device-tree/le-dt-id

#6

Does your device goto CoreELEC screen and then go blank? Can you SSH?

Need more information here.

#7

In 8.95.7:
cat /proc/device-tree/le-dt-id
gxbb_p201_2G

It’s a simple S905 and no, it get stuck at begining brand logo screen. Do yo need any other information from 8.95.7?

#8

What GUI resolution do you have?
Could you try fresh install on different card to check if fresh build works?

#10

If you are stuck before CoreELEC logo then either you have a dtb issue or something is wrong with your SD or eMMC.

Burn the image to a fresh SD card and it should work.

#11

I’ve just tried with fresh install on other SD card and the result has been the same.
With the default dtb.img it boots in Android stock system and copying manually the gxbb_p201_2G.dtb it get stuck at the logo screen.

Thank you for your support.

#12

There is no default dtb.img in CE images.
Your box, according to specs on the page you linked, has a S905X SoC, not a S905, so you need to use gxl_p212_2g.dtb with it.

#13

Sorry but the link that I posted must be wrong or must be an upgrade of the original model.
I’m pretty sure that mine is a S905 model of the first generation.

Look this link, it’s my model but mine has 2G of RAM(sorry it’s in spanish but you can read the specs perfectly):

As I’ve said before it’s working perfectly with CE 8.95.7 with gxbb_p201_2G.dtb

#14

Ok now it is solved.
I’ve tried with gxbb_p200_2G_100M.dtb and now it’s working. I don’t know what is the difference between p200 and p201, but when it boots with Android it reports a p201 board…

Anyway, thank you for your help!

split this topic #15

2 posts were merged into an existing topic: IR remote not working