CEC flag and Kodi

At first I thought my autostart.sh script to change the CEC flag was not running and began writing a post to that effect. I since think I’ve figured out that although my script runs, something else is coming along later and reverting the CEC flag, causing my Ugoos AM6 to turn itself off if the HDMI input is changed.

Given the file date (boot time) it seems something in Kodi is coming along later and overwriting the cec flag setting? How do I tell whatever is doing it to ‘stop doing that’?

Any thoughts on this? Having to deal with dumb CEC flag handling is really annoying. I don’t want my Ugoos box turning itself off when I change inputs. I have found how to disable the ‘feature’ on my Samsung TV (turning off Anynet) but I am also trying to understand why my settings are being overwritten.

When run from the command line, it does the appropriate thing.

For reference, if anyone else wants to edit the /flash/config.ini I am using this script located at ~/.config/autostart.sh (mode 0755)

htpc:~ # cat ~/.config/autostart.sh


mount -o rw,remount /flash
cat /flash/config.ini | sed -e "s/cec_func_config='7f/cec_func_config='7e/g" >/flash/config.ini.new
mv -f /flash/config.ini.new /flash/config.ini

You did not say which version you use but with current 19.2 you only need to use the setting in CE settings addon. That is also most likely to overwrite your setting. Set it u der settings-CE-hardware. Hope that helps you Sir

Yes, on 9.2 CEC is handled by CE settings. On 19.2 it’s handled by libCEC settings.

Turn off the wake up on active route and it should save 7e in config.ini.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.