CEC not working on 9.2.6, 9.2.7, 19.1 on TV LG

I have problem with CEC and TV LG OLED65CX. I have used CE 9.2.5 and there is CEC perfectly working. But when a try to update on 9.2.6 and highest I cannot use CEC. The CEC is completly off. I have tried many things. I rewroted physical adress, start and stop CEC, new cable, another HDMI port in TV, many clean instalations. Log from my Odroid N2+ is: http://ix.io/30Ot
Can you help with this problem?

does it start working when you send “CEC Activate” command from Yatse Android application?

Compared config.ini.
In my config.ini this line is commented:

# cec_func_config='7f

On my setup (Kodi Matrix):
͏͏ ͏͏ ͏͏ ͏͏ ͏͏ ͏͏ ͏͏ ͏͏ ͏͏ ͏͏ ͏͏ ͏͏ ͏͏ ͏͏ ͏͏ ͏͏ ͏͏ ͏͏ ͏͏ ͏͏ ͏͏ ͏͏ ͏͏ ͏͏ ͏͏ ͏͏ ͏͏ ͏͏ ͏͏ ͏͏ ͏͏ ͏͏ ͏͏ ͏͏ ͏͏ ͏͏ ͏͏ ̷ ͏͏→ TV (HDMI 1)
N2 → HDMI switch → |
͏͏ ͏͏ ͏͏ ͏͏ ͏͏ ͏͏ ͏͏ ͏͏ ͏͏ ͏͏ ͏͏ ͏͏ ͏͏ ͏͏ ͏͏ ͏͏ ͏͏ ͏͏ ͏͏ ͏͏ ͏͏ ͏͏ ͏͏ ͏͏ ͏͏ ͏͏ ͏͏ ͏͏ ͏͏ ͏͏ ͏͏ ͏͏ ͏͏ ͏͏ ͏͏ ͏͏ ͏͏\ → AVR (HDMI Media player)

CEC works absolutely fine but… only when in the splitter (switch) I have switch off the button EDID and switch on the button ARC:

Use this instruction to configure correct port.
It works correctly on 55CX and N2+.

can you write to me physical adress for TV LG with N2+ conected to HDMI port number 1? I have written adress 1000 and 1100 but no answer. Where in menu I have this physical adress write?
Thank you

can you hellp me, where is “CEC activate” command in Yatse?

thank you, but it isnt work
I am sad because CEC was working on 9.2.5 but on 9.2.6 and highest not works.

I have to admit its a bit intermittent on my c4. I have to turn the TV off or switch hdmi channels to get it working again.

In my combination LG CX a N2+ works perfectly in 9.2.5 and older. But in newest 9.2.6 etc. in any case.

then you do something wrong, sorry

and developing support for 9.2 is stopped, use CoreELEC Matrix 19

When trying to set up the CEC, I tried everything according to the procedure. Can you please advise me anything else? Yes, I know that 9.2.x is no longer developing, so I wanted to switch to 19.1, but unfortunately I can’t do that without a working CEC.
Can you write to me physical adress for TV LG with N2+ conected to HDMI port number 1? I have written adress 1000 and 1100 but no answer. What can ihave write?
Thank you and best regards

Make a clean fresh rc4 install and make logs like requested here:

Hello, I did clean install and here is log: http://ix.io/3lvU
It’s still not working :frowning:
But I believe it will work :slight_smile:

Post your cec_CEC_Adapter.xml
You will find it in Userdata/peripheral_data

The next logs from 19.1 nightly:

and cec_CEC_Adapter.xml
cec_CEC_Adapter.xml (1.4 KB)

You still do not have enabled kodi debug login nor component libCEC,
no log no problem…

Can you help me, where in Menu I can enable kodi debug login?
Is it this file?

kodi.log (101.3 KB)



There is new log:
kodi.log (115.7 KB)
Thank you very much for you help.

Still no libCEC component logging active…