CEC not working

You just can test the tar on all Amlogic-ng devices :wink:
But Panasonic is just strange and make problems everywhere with CEC.
There is some info around here in the forum, I guess it was: deactivate set to active source on kodi start in CEC options.

Ok Thanks I’ll give it a go! I tried deactivating active source it didn’t work. Strange thing is CEC worked perfectly on my old mecool s912 device with the same tv it’s only since I upgraded to the vim3 it’s broken

The ARB_LOST issue was treated in this thread a couple of month ago. As far as I can see this was somehow fixed, but the corresponding build is not available any longer.

It is no help, but i have the same Problem, too.
Philips TV, Denon x2600h, Odroid C2.
Mostly CEC not correspond with TV <> Odroid.

I have now done a measurement with my oscilloscope on the CEC bus of the N2.
This is the transfer protocol:

[   20.833100@5] cectx ff80023c.aocec: try to send data by cec_ll_tx, len 1
[   20.859895@4] cectx ff80023c.aocec: CEC tx msg len 1: f0
[   20.889037@3] cectx ff80023c.aocec: try to send data by cec_ll_tx, len 2
[   20.915905@5] cectx ff80023c.aocec: CEC tx msg len 2: f0 8c
[   20.928535@1] cectx ff80023c.aocec: warning:ARB_LOST

The protocol shows the transfer of 0xf0 (ping TV) was successful.
The second transfer of 0xf0 0x8c fails by arbitration lost.
It just stop transfer after the third bit - I don’t know why.
The arbitration lost error happens randomly.

We got a hint from HK/Amlogic to remove a property in the dtb.
Maybe the CEC issue is fixed now!


Just update your device with this tar and have a test if the CEC issue Couldn't initialize the CEC adapter is solved!

1 Like

Yes! Works on my Mecool KM9 Pro :+1:

Was it working before, yes/no/sometimes?

No, never.

1 Like

Have you tested it on S922? To make sure there is no regression…

Sadly didn’t work for my case (N2->EGreat or LG Receiver->Samsung QLED).

N2 still does not wake up - assuming its in Suspend mode and not actually shutdown.

Will try the boot loader inject thingy next.

This is about the Pulse Eight adapter issue in Kodi, not about wake up!


Sorry what is? The patch or the whole thread?

Going through the thread, i see lots of comments about wake up hence my assumption that it was at least partially about that.

First of all: Thank you very much to all of you for helping to get rid of a quite nasty issue.

With Portisch’s yesterdays version for the first time CEC works on my N2 with a Philips TV’s remote control via Marantz AVR.

Regarding wake up: So far I recognised that boot up from N2 causes TV to wake up. Shut down of Kodi causes TV to switch off.

I installed that version too and i had to switch the input only once to start the n2. At least the last 2 times it started that way.


it will be this version works for the C2, too?

@Portisch This has solved my N2 CEC issue now. Thanks so much for this :slight_smile: Could this get added to the next stable Release.

The fix is already some time included in the nightly so if nothing bad happen it is included in the next stable release too.

@Portisch Thanks i will check it out again as last time i installed it, it did not work.

It will be in the next stable build, not in the existing one.

1 Like