CEC not working

And your hardware setup? How and what is connected together?

And please open a SSH connection or even better use a UART adapter if available and send this command as soon as possible:
echo 1 > /sys/class/aocec/dbg_en

Then wait for 1-2 minutes and run dmesg | paste again, thx.

Okay ran that command, here’s the paste:

http://ix.io/2hZm

My setup is very simple. Odroid N2 connected directly to LG C8 via 3 foot HDMI cable (certified 18gps).

Probably not relevant but using 1gbs ethernet and USB3 stick for extra storage, booting directly to SD card (no EMMC).

You are sure with 9.2.1 CEC is still working? Please downgrade or create a new 9.2.1 boot media and try again. I never have seen a issue like this. Also I found some information about the C8 and firmware and broken simplink.
If this 9.2.1 is working fine please upgrade again to 9.2.2 and try again.

What is the issue actually? CEC worked fine in 9.2.1 until LG pushed a firmware update maybe 2 weeks ago at which point it stopped working. No idea if those two things are related btw because the update may have had nothing to do with CEC.

So u updated the firmware on your TV and ask here because it does not work with 9.2.2? :crazy_face:
Would be a necessary fact for us that the issue even was there with 9.2.1 !

Maybe it’s time to contact you LG distributor?
CEC does not work as your TV does not release the CEC bus line.
So CoreELEC can not send any message…

I didn’t update anything - LG forces firmware releases and then reboots the TV & the end-user has no choice to decline them.

I did some tests and there’s definitely something screwy with Coreelec CEC and my tv. I tried two things. First, I tried switching the cable to a different port and rebooting. That did nothing. Then I tried moving it back to its original port and rebooting. Nothing.

Then I tried moving it back to its original port and using the LG remote to power the TV off. This worked. Therefore there’s something that happening with CEC when the TV is powered off that’s not happening during either a full shutdown or reboot of the Odroid. I think the reason I noticed this at all is because I have my Odroid reboot itself on a cron once a day so something in the reboot was clearly not releasing the CEC bus line in a way that powering the TV off did.

No idea if that helps or not.

What do You want to do by CE developer ?
It´s not a CE issue.

You told us the setup is very simple, but You are running cron jobs etc.

I’m not sure what you mean - a cron job to reboot isn’t remotely complicated. I don’t know anything about CEC. What I discovered is that rebooting the Odroid doesn’t release the CEC bus line whereas powering down the TV does.

I have no idea if this is something fixable by the Coreleec team or not but I’m reporting it because LG makes a very popular line OLEDs and I stumbled upon this issue and have seen others reporting CEC issues and maybe this points to a solution.

No it’s not fixable by CE. When the TV does not release the CEC bus any device can do anything.
So should contact Lg support.

Okay well knowing it’s an LG issue may hopefully reduce the bug reports on something the CE team can’t fix.

Are You sure ?
Did You try a fresh install without cronjobs and addons
Another cable ?

I can´t believe CEC isn´t working on LG TV - LG isn´t a cheap brand

1 Like

Maybe shooting blanks here, but did you check Simplink setting on your TV, just for know, if update doesnt change it to some sort of default “OFF” by a chance? :slight_smile:

Also try change sources, if that doesnt help (for some TV it was only way to activate it, but last time I need this was years back)

My N2 also connects directly to my LG C8 OLED, and i have no problem whatsoever. In fact, 9.2.2 works better than 9.2.1.
On 9.2.1, after starting up, i need to wait a couple minutes or so before CEC is working.
On, 9.2.2, after starting up, it’s only several seconds until CEC is working. Much faster…

If your CEC is not working, try changing the input source and back.
For example: HDMI1 to HDMI2 and back to HDMI1.
That’s what I did before… but this was many updates ago…

I’m using a Sony TV and CEC (they call it Bravia Sync) wakeup is working more or less , but it’s suboptimal.
I always have to switch the inputs to wake up the Coreelec box.
Is this also the correct command to debug my problem or is there some config that i simply have to change?

Only a UART log can show what is happening on the CEC bus while suspended/powered off. If you do not have a UART access to your device you maybe try this generic adapter. It works with a lot of Amlogic boxes:

Yes i’ve already seen this board. But spending money for the SD Card UART Adapter and the UART Adapter itself is a bit too much for my problem.
This would cost me more then i paid for my X96 Max Plus at all :sweat_smile:
Thank you anyway

The price is higher as it is “generic” UART Adapter what you can use also on other devices. So you have to buy it only once.

Yeah i know but until now I only have one device and I don’t even know if the debug board will work with my X96 Max Plus at all.
I will think about it…

It took a while, but i finally got the SDIO Board and a UART adapter.
Here are the logs with the CEC commands: https://paste.ubuntu.com/p/2sRQMShHn9/

About | FAQ | Terms of Service | Privacy Policy | Legal Notice