CEC remote problem

I upgraded my Minix NeoU1 to CoreELEC 9.2.5 (from LibreElec 8) yesterday and I can’t get the TV’s (Samsung) remote to work over CEC.
If I run the builtin Android it works fine.
If I plug in the LibreElec card it also work fine.

From what I read there is some configuration to do to make IR remotes to work.
But as I understand CEC should work out-of-the-box.

What might the problem be?
I hate to be forced to revert to LibreElec over an issue like this.


You may need to try changing to a different libcec version:

Almost all of my TVs are old and I have no problems with CEC, I also have a LG TV from the year 2012 in which CEC works great, I also have another recent LG TV from the year 2020 in which CoreELEC CEC works really bad, I can not prevent the TV turn off the CoreELEC device (although I have the configuration of /storage/.config/shutdown.sh so that all my devices cannot be turned off because WOL has never worked for me on wireless networks). To solve this I had to disable CEC in CoreELEC and in the TV, and use the command fw_setenv cecconfig cec0.

In summary, the CEC configuration in CoreELEC seems complex to me and does things that one does not expect. I have also tried using libCEC 4.0.7 (command: touch /storage/.config/libcec-4.0.7.conf) in CoreELEC for the S912 processor and it doesn’t work.

In contrast to cubimol who has an older TV, mine is from last year, so I thought I’ll try with the newest libcec.

I have tried
touch /storage/.config/libcec-4.0.7.conf
And the libcec links seems to point to 4.0.7
# find / -name libcec* | xargs ls -l
-rw-r--r-- 1 root root 0 Nov 3 10:23 /storage/.config/libcec-4.0.7.conf
lrwxrwxrwx 1 root root 11 Oct 28 19:13 /usr/lib/libcec.so -> libcec.so.4
lrwxrwxrwx 1 root root 20 Oct 28 19:13 /usr/lib/libcec.so.4 -> /var/lib/libcec.so.4
-rw-r--r-- 1 root root 353116 Oct 28 19:13 /usr/lib/libcec.so.4.0.4
-rw-r--r-- 1 root root 357252 Oct 28 19:13 /usr/lib/libcec.so.4.0.5
-rw-r--r-- 1 root root 357252 Oct 28 19:13 /usr/lib/libcec.so.4.0.7
lrwxrwxrwx 1 root root 24 Nov 3 13:32 /var/lib/libcec.so.4 -> /usr/lib/libcec.so.4.0.7

However it still says 4.0.4 in KODI, Setup, Input, Periphials

When I try touch /storage/.config/libcec-4.0.5.conf instead I get 4.0.5 but still TV remote don’t work. :frowning:

Read the how-to more carefully:

I read that, but I did not understand the implication - does it matter that the wrong versions are shown?
Since you wrote that I imagine that the answer is “yes”.

Anyhow I got it working.
I read this: (It’s more related to Samsung and Kodi than it is to LE so I hope it’s OK to post the link.)

Samsung TV:s seems to remember too much.
I unplugged the HDMI cable (I’ve done the before without any success) and powered off everything for about an hour. (Just unplugging it and plugging it in right away was not enough.)
Turned everything on again and plugged in the HDMI.
After that both the TV’s remote and the keyboard I have connected to the TV works in CoreELEC.


Good job testing and sharing with the community! You’re setting a great example for others!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.