Ceemmc and Minix T5 failed install

Hi all,
tried installing Coreelec on Minix T5 with ceemmc but it states that it is unsupported device.
Naturally, with ceemmc -x command i bricked the device, will restore today, no issues here.
Is the T5 even supported, it states on guide page that “Minix” is supported but it doesn’t specify for which chipset.
If its not supported how to get Coreelec installed on internal emmc storage like before with" installtointernal"?
Thank you

Use the verbose output and post the log:
https://wiki.coreelec.org/coreelec:ceemc_use#using_the_ceemmc_tool

Thx Portisch, will do later when i restore stock os back and boot CE from sd again.
Now its just boot looping :smile:

Install the 19.3-Matrix versions for MINIX NEO T5. Newer versions have a bug that causes a “restart loop”.
I have this model and same problem.
Starting version 19.3 from SD / USB + command “ceemmc -x” will fix your problem. Remember to immediately disable automatic update in KODI settings and install coreelec without internet connection.

Hi,
I’m new here. I would like to get some help.
I just purchased a used Minix Neo T5 today. It works fine in Android TV mode.
But I would like to boot into CoreELEC using a microSD card. The card I have is a brand new “SanDisk Ultra microSDHC UHS-I Card 32 GB SPEED up to 120 MB/s A1 for faster mobile app performance.”
I followed this tutorial to prepare the SD card in Windows: https://theminixforum.com/index.php?threads/tutorial-coreelec-on-the-t5.3692/
After Rufus created the image, I had to assign a drive letter to the FAT partition on the card, that’s not a problem. Then I copied the g12a_s905x2_2g_1gbit.dtb file from the device_trees directory to the root directory of this FAT partiton and renamed the file to dtb
When I do the power on thing with the paper clip (holding the reset button) I get to see the white MINIX logo for a few seconds and then the screen goes black. I release the paper clip at that time, but nothing. The screen remains completely blank. I waited for 15+ minutes, but nothing is happening. The device just does not seem to boot from the micorSD card for some reason.
I tried the above using the following img files:
CoreELEC-Amlogic-ng.arm-9.2.5-Generic.img
CoreELEC-Amlogic-ng.arm-9.2.8-Generic.img
CoreELEC-Amlogic-ng.arm-19.5-Matrix_rc1-Generic.img
and I always get the exact same result (just a completely black screen after the logo).
I also noticed one more thing. Even when I do not hold the reset button with the paper clip when I power on the device, if the microSD card is inserted the device does not boot up into Android TV. It get stuck after a few seconds. So it seems to me that no matter what I put to the SD card using Rufus, the device won’t boot up when this microSD card is inserted. The card is brand new and works fine in my Windows PC…
Any suggestion? Could it be that this particular microSD card is not compatibe with the Minix Neo T5 ?
Any help would be appreciated!
Thanks,
Zoltan

dtb or dtb.img ?

@vpeter Yeah, to just dtb and not to dtb.img – and that was the problem. And I just figured it out on my own before reading your reply – after wasted 3.5 hours on this today… :frowning: The screenshot in the PDF file just showed dtb with no .img file extension – thanks Windows for not showing all file extension all the time… :frowning: :frowning: :frowning:
Thanks for the quick help though. You pinpointed the problem right away! TY!

1 Like