Command to completely disable CEC in "config.ini"

Is this just for Odroid or more common streaming boxes like my Tanix TX9 Pro and my mates Beelink GT King??

/flash/config.ini

No such folder /flash ??? I assume you are talking KODI / CE system folders yes ?? I dont want to be messing much with Android as I really loathe that OS so much and try to avoid it as much as possible. Its why I will not entertain an Android based smart phone despite some excellent hardware platforms like Huawei gear which I really rate. I stick to my iPhones thanks as far better to use and far safer too, as well as solidly built too. But hey I digress, sorry

You need to ssh. We don’t use Android. We are a linux based operating system.

Okay thanks for that I will try ssh as have many times before but not for some while. Yes I know we don’t use Android but I have come across cases where the default Android system set up in our streaming boxes does affect CE operations and was guided on here once to check and change something in the Android settings files, just cannot remember what.

Editing the contents of the /flash partition.

This partition is mounted read only.
So you do need to ssh into the device and remount the /flash partition to make it writable.

mount -o remount,rw /flash

after which you can then edit the config.ini file

nano /flash/config.ini

Then reboot.

1 Like

Thanks Kostaman. Sorry for late reply but not been available for a coujple of weeks. I did take a look at the config.ini file and it has a single line WOL=0 So it is already disable it appears. Still have this annoying problem losing CEC and ARC between the TV and Onkyo AVR requiring a reboot of the TX9 Pro box running 9.2.3 which then clears thsio problem which comes back sometime later for no apparent reason I can put my finger on. And happens again even though I leave the TX9 box running all the time when not being used.

Some more test I have carried our shows that if I power down the box but leave it connected to the power then I lose CEC/ARC TV to AVR, so this thus appears not to be a CoreELEC problem but something in the box hardware that is interfering with the Onkyo CEC/ARC funcfion. BUT if I disconnect the power enitrely from the TX9 or unplug the HDMI lead to the Onkyo then the CEC/ARC comes back fine between TV and AVR ?? So does that help in giving a clue as to solving this problem that others here, plus my friend with a GT King box, also have too ??

Thanks in advance for any response to this problem or any others with any relevent input

Cheers
Ray

Did you try all libCEC versions?

What does it have to do with WOL?

The /flash/config.ini file deals with WOL and is the only line present. Mine was set at WOL=0 and was mentioned to me to ensure that this WOL was switched off. Yes I wondered why that was too.

Thanks Portisch. Will have to look at the licCEC 4.0.7. But where do I download it from ?? Or will it already be available in the .config folder though I doubt that ?? I will take a peak.

You can add other options there even if there is only one line currently present.

Is there a list of available options for boot.ini and config.ini?

thx, but why is the max_freq_a55 for C4, which @cdu13a added in nightly_20200725, not shown in the list? Is it complete? What’s about boot.ini?

It is best to look at your own boot.ini. there are variables past to the kernel. Those you can normally change.

You only can modify config.ini. the max_freq_a55 is for the SM1 SoC added.
You can set max_freq_a55=xxxx (SM1) in config.ini and it will be handled correct by boot.ini.
Internal max_freq_a55 is same as max_freq_a53 so you also can use max_freq_a53=xxxx (G12*)

So do I need to add the line cec_func_config=‘00’ to my config.ini file to disable all CEC functions or is it already by default set to all off = ‘00’ ??

Also remember that I have a Tanix TX9 Pro box, not an Odroid so assume this all still applies to my box. Also just awaiting deliver of an X96 Max + S905X3 4/64GB box which is ridiculously cheap for such a high spec box :slight_smile:

As the Tanix TX9 Pro is a S912 SoC I am not sure if it can be disabled completely. At least not in suspend mode as CE does not have control over the bootloader bl301 blob. All other devices using Amlogic-ng image including bl301 injected and/or Odroid N2/C4 also support disable of CEC for Wakeup and can be set in Kodi CoreELEC Settings.

so set in config.ini (if not available in CE settings):

cec_func_config='0'

should disable it, yes

Different libCEC versions can be chosen by open a SSH connection and type:

remove any libcec config (default 4.0.4 will be used):

rm -rf /storage/.config/libcec-4.*.conf

enable libcec-4.0.5:

touch /storage/.config/libcec-4.0.5.conf

enable libcec-4.0.7:

touch /storage/.config/libcec-4.0.7.conf

When CEC is working after booting into CE and CEC is stopping working later it’s more related to libCEC then the CEC driver itself.

The problem is that if you disable libcec the kernel continues processing cec:

So setting cec_func_config to ‘0’ should turn it off completely.
You could also remove it from dtb if it doesn’t.

About | FAQ | Terms of Service | Privacy Policy | Legal Notice