Compilation Error

Hi

Just add problem for compilation. https://pastebin.com/g8RJMbiB

on Linux ubuntu 4.15.0-22-generic #24-Ubuntu SMP Wed May 16 12:15:17 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

Thx for your help

Run scripts/clean hauppauge and try again please

I did already and reformat also my plateform for build (fresh install)

First build I get that error https://pastebin.com/vj8r5yeB

If I retry to build I get error https://pastebin.com/g8RJMbiB

I build for PROJECT=Amlogic DEVICE=Odroid_C2 ARCH=arm make release

It’s make image we use

Nevertheless we have seen this issue before, it’s as a result of conflicting compilers installed on your system.

If I remove hauppauge package build in option project, it’s working great until the end.

The issue has now been resolved, pull the latest changes and it should be okay.

1 Like

I confirm :slight_smile:

@anon88919003 Hello, I have been trying to build CoreELEC from the sources, but I have been getting some errors during the final part of the compilation process:
https://pastebin.com/iwDxhAKv

As far as I understand, fakeroot cannot be used with setuid executables (I believe chown and a couple others don’t fall within this category), so I must be missing something else. Any ideas on a probable cause for this?

Solved. My bad, it seems my build environment had become tainted. A fresh install solved the problem.