Compiling CE Matrix build

First congratulations on the Matrix build it runs very well on my N2. I am however having major difficulties building CoreElec 9.2 and coreelec-19 branches and also more specifically my addon pvr.nextpvr

This is extremely important because my addon is failing for odd reasons but I can build the newer release version or a custom version with debug information to test.

Is the build system compatible with Ubuntu 20.04> I have never had issues with CE or LE in the past? It doesn’t even start to build a toolchain

If so I have unsuccessfully tried quite a few things notably.

PROJECT=Amlogic ARCH=arm DEVICE=AMLG12 make image

Traceback (most recent call last):
  File "scripts/genbuildplan.py", line 367, in <module>
    REQUIRED_PKGS = processPackages(args, ALL_PACKAGES)
  File "scripts/genbuildplan.py", line 296, in processPackages
    raise Exception(msg)
Exception: Invalid package reference: dependency qca-firmware in package linux-firmware::PKG_DEPENDS_TARGET is not valid

and

PROJECT=Amlogic-ce ARCH=arm DEVICE=Amlogic-ng make image

<<< CoreELEC-Debug-Scripts:target seq 6 <<<
config/functions: line 1593: /media/acer/CoreELEC/build.CoreELEC-Amlogic-ng.arm-19/.threads/locks/CoreELEC-Debug-Scripts:target.install.owner: Invalid argument
*********** FAILED COMMAND ***********
echo "${this_job} ${PARALLEL_SEQ} ${task} ${pkg}" > "${THREAD_CONTROL}/locks/${pkg}.${task}.owner"
**************************************
FAILURE: scripts/install CoreELEC-Debug-Scripts:target has failed!

Thanks in advance

Just run make or make image.

I’ve tried those and get the same line 1593 that I showed above.

Can you try it with Ubuntu 18.04? There we are sure it’s working. I never tried it on Ubuntu 20.

I freed up some space on my system drive and I’ve got to step 86 so far. Is it possible it won’t build on an NTFS drive?

Also I am just running make. Does create_addon create the required toolchain for addons or is it best to create the image first. I only have about 40GB free.

No, it’s not needed to build a image before. My build folder is about 30GB, so yes maybe you run out of space. Also please use > 4GB RAM. If less you will need to create a swap file as otherwise strange building errors can happen.

Ok thanks I have16GB RAM no worry there. Building the addon is compiling now, I just need to remember the tricks to build for another source.

To confirm the default ./scripts/create_addon pvr.nextpvr is appropriate for the odroid n2

Thanks for the help

So it starts compiling but it fails

Executing (target): cmake -GNinja -DCMAKE_EXPORT_COMPILE_COMMANDS=ON -DCMAKE_TOOLCHAIN_FILE=/home/martin/CoreELEC/build.CoreELEC-Amlogic-ng.arm-19/toolchain/etc/cmake-armv8a-libreelec-linux-gnueabihf.conf -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=MinSizeRel /home/martin/CoreELEC/build.CoreELEC-Amlogic-ng.arm-19/build/pvr.nextpvr-8.0.1-Matrix
CMake Error at /home/martin/CoreELEC/build.CoreELEC-Amlogic-ng.arm-19/toolchain/share/cmake-3.19/Modules/FindPackageHandleStandardArgs.cmake:218 (message):
  Could NOT find TinyXML2 (missing: TINYXML2_LIBRARY TINYXML2_INCLUDE_DIR)

Is there are step required to add this library to CoreElec. I know for Kodi build I do this in the build process via cmake https://github.com/kodi-pvr/pvr.nextpvr/tree/Matrix/depends/common/tinyxml2

In file packages/mediacenter/kodi-binary-addons/pvr.nextpvr/package.mk add tinyxml2 dependency

PKG_DEPENDS_TARGET="toolchain kodi-platform tinyxml2"

Thanks that did it. Do I need to send a PR?

Send it to https://github.com/LibreELEC/LibreELEC.tv

Thanks. https://github.com/LibreELEC/LibreELEC.tv/pull/4890 created

I am pretty sure this can be marked solved the issue must be builds fail on NTFS.

2 Likes

@vpeter are you sure I should not do a PR here. I notice CoreElec did the pvr version bump and LibreElec did not so they are not in sync.

1 Like

Yes, you need to PR directly to LE as we are only a fork of them.
I just have bumped the PVR addons as we are a step further then LE with Kodi. The bump will be dropped again when LE is bumping the PVR addons by themselves.

If needed we can pick your PR till it get merged by LE.

No worry I am now using CE for testing my addon changes and know what to do. I just wanted to make sure that it gets done for others. As long as LE just use /tools/mkpkg/update_binary-addons it won’t happen.

1 Like

About | FAQ | Terms of Service | Privacy Policy | Legal Notice