Constant skipping when trying to play internet stream

Hello,

Looking for some help. I am in the process of switching over from Kodi on a 2015 Shield TV to CoreELEC on an OdroidN2+. Prior to that I tried out OSMC on a Vero4K+ but had a lot of issues playing Live TV and using the Netflix addon so I abandoned that. I just got my new hardware a few days ago and I have been very happy so far, CE and the N2+ play everything I had issues playing on the Vero perfectly.

But yesterday I tried playing an internet stream from an strm file with a m3u8 url and the video just skips constantly. Like every second for the whole video. I always use this method to watch these particular streams from a paid subscription I have, and I tried multiple streams from that source and they all have the same problem. Playing the same stream on my Shield TV however, also running Matrix 19.5, works perfectly. It also played fine when I tried playing it on https://www.hlsplayer.net/

Can someone please help to fix this? I use these streams a lot.

Here the log. I tried using the CE log uploader but it kept giving me an error so I used the log uploader from the official Kodi repo. https://paste.kodi.tv/rugipuvoma

I had an old rpi3 lying around, so I downloaded LibreELEC and tried playing the same stream and it worked flawlessly. Please help, I’m really hoping the N2+ and CE combo can be my new media center solution but if I can’t get this fixed it’s not gonna work for me cause I watch these streams too often

Can you post url for this problematic m3u8?
Did you try latest with LE-Kodi 20 final, to see if you get the same behavior?

Sure, here is an example https://d1u8ea759yl6fq.cloudfront.net/out/v1/b84ff84d64f140f8ba7b5e17962c97ec/f3e54b219cdb4fba817eb32574c670a5/11d7bbbb8b5b427ea0ebd714efe52583/index.m3u8

And yes I updated to 20 final last night and it is still the same behavior

Hmm, cannot play it even with VLC on Win10 PC. Will have to fire up my Android on N2 to see how it behaves on my “proper” Smarters Pro IPTV player

Seem to play fine here Imgur: The magic of the Internet

1 Like

What type of device are you using?

I tried on both an SC2 and T7. I have others like N2 but I can’t see anything special about the streams in that would be a difference.

Okay thanks for checking it out. Hmm, so I guess that would mean it’s a strange issue with just the N2/N2+ or I got a faulty device?

I noticed that in the logs there are all these lines that say
ffmpeg[0x24a4eb8X]: [hls] Skip
Is that normal or does that actually mean the stream is skipping?

Anyone else using an N2 or N2+ able to try playing the steam?

I have an N2 (CE 20), so I placed the URL into a strm and it works fine.

Also plays fine on W11 and VLC.

Okay awesome, thank you! But also super weird. Don’t understand why it’s only my device with the problem :confounded:

Maybe worth a quick clean install onto an SD and just place the URL into an strm to see if that works.

Yea that’s a good idea, sd card will be quick and easy so I don’t have to wipe my whole setup to test it. I’m gonna try this tonight after work.

Whoa, that worked!! Played flawlessly on the fresh install from SD. I guess I will wipe the eMMC and try a fresh install on that next :crossed_fingers:

Success!

After a clean install on SD, as @gregeeh suggested, to verify working there, I switched back to eMMC and tried a HARD reset from the CE addon. After hard reset, tried playing on a clean setup… same issue. So then I removed the eMMC module and reflashed CoreELEC. Reinstalled the module, booted up, and this time it worked! Played perfectly. I was even able to restore from a backup I made before doing the hard reset and restore my whole setup and verified it still played fine afterwards. So no weird setting or addon was causing the issue. Super weird to me! I don’t know much about hardware, and components, but seems so weird that Netflix, EmbyCon, ESPN, and LiveTV from my PVR all played everything just fine and it was just the m3u8 streams having the issue. That makes me think software bug with that specific stream format or something. But nope. Reflashing the eMMC fixed everything.

Welp… I am thrilled, have been loving CE on my N2+ in the week or so since I made the switch. That was the only issue.

Also, the backup and restore feature in the CE addon is fantastic! I had used the Backup addon from the official Kodi repo in the past and I always had issues with it. CE’s seemed way quicker and was super simple to use.

Thanks for your help everyone!