CoreELEC 19.1-Matrix_rc1 Discussion and kodi.log (87.0 KB)

Checking your kodi log we can see there are some banned addons (check and therefore no support can be given. Try a clean install and the problem persists please post a new log. But I can tell you that you have some nasty ones there, like Indigo, that probably are causing your problems. Maybe you now have a mining machine without your knowledge…

1 Like

On matrix 19.0 was not usage in idle. But i try clean install also on some other sd card.

No backup, upgraded. No problems on 19.0. Now on rc1 upgraded from 19.0 weather not working anymore, everything else seems to be fine.

I will try to make sure weather addons data is wiped, and if that does not help, try with English ui. But, if English ui is required (which was not on 19.0), it’s a bug

After all, weather is not most important functionality, but nice to have it

I tried to do a clean install of 19.1 rc1 on a VIM3. When I insert the sdcard and boot I get a blank screen. Does anyone know what firmware version is required for 19? I have 9.2.7 installed on another sdcard which is working fine.

This is a common problem. Try this workaround:

Where do I put the file on the sdcard before installing?

Into .config/Configfile. What do you mean ‘before installing’?

Usually you get a weird colored screen (pink, mint, teal, magenta …), if your tv is powered on after your box is. Then your box can’t read EDID on start. Therefore aforementioned Autostart comes in play and forces Kodi to switch once the resolution.

If your box doesn’t even boot properly, you have an entirely different problem.

You don’t need “” file for installation; just install fresh image and if initial screen is not shown, wait for a couple of minutes for installation to finish. Then you should see Kodi Home screen.
If the installation does not finish, then there is some other problem that “” cannot fix, as far as I know…


Sorry for my poor english,its not my native language.
And sorry if wrong thread…
My question is:
CE 9.2.7 NG works well with my S905X box…
Is CE 19 Matrix compatible with my box?
Im not really understand the details.

Unfortuanteley - as mentioned on CE19 thread too - I still got stuttering problems with H264 videos on my Mecool KI Pro box /S905D). I can narrow it down to H264 as once I set the hw acceleration of H264 to “never” the stutter is gone…I could live with that but then the main problem on some HD channels is that the framerate is drastically cut down like if it is at ~5fps. Unsure what causes this. Logs had been posted in CE19 thread. Don’t know what else I can do to help fixing this?

Yes. Both run on the 4.9 kernel, your box should run fine with Matrix. But to be safe, use a new SD-Card at first. Then you can test the heck out of Matrix. If it doesn’t satisfy you, then change back to Leia.

Many thanks and best regards!

@byomi What add-on do you use for Sky Germany? Is there a one that still works?

I can cofirm that CE 19.0 Matrix runs on my Mini M8S II S905X box.
But only from SD-Card or USB stick.
I tried to port it to the internal memory using the CEEMMC tool but after that my device was bricked.
I know it’s not on the list of officialy supported devices but I hope one day it will be because CE runs far better on the internal memory for me. That might be because of my slow USB stick but I’don’t want to buy a new one just for that purpose.
Until then I’ll stick to the Legacy builds.

What did you have in internal when you tried cemmc?

I used ceemmc with the first CE19 release on March beginning. After running it my Mecool KI Pro box was bricked and I needed to open it and locate the points on the chip to get it reflashed again with Amlogic tool. So be cautious trying that. But I am still interested in it to be able to abandon my sdcard. I chosed to replace the ANdroid partition and tried to use the full memory for CE. Maybe that was my fault and I should have been chosing the option to keep it with Android datat? I read that CE19 RC1 has some changes regarding for ceemc but unsure if I should retry again…

@ Vasco: At that time I had CE 9.2.6 in my internal.

@byomi: I tried the dual boot option too afterwards. Same result.

To use ceemmc you must have android in internal. You may try again but always be prepared for a recovery operation.

1 Like

Ok understood that with ceemc. Maybe try again later once I solved the problem with video playback (stutter / jiddder). Tried to play Minions films while log. As stated earlier the stutter / jidder is solved when disabling h264 hw acceleration but then I get low framerate playback on HD channels in IPTV simple client and that’s no solution. Never had problems on CE9.2 (non-NG). Here are my logs:


Log (Stutter / Jidder with VideoPlayer::OpenFile: /media/sda1-usb-SanDisk_Ultra_US/Minions (Hd).mkv):


This forum user has the EXACT same problem. Tested his file and it is identical issue: