CoreELEC 19.1-Matrix_rc1 Discussion

This is a stable release. The reason for the rc is that we felt there were some corrections needed since 19.0 and there’s still no date for Kodi 19.1. This way we decided for an intermediate release that we felt was important for users.
This terminology will be adopted in future releases everytime it’s needed in similar situations.

3 Likes

Thanks for the info! I just didn’t want to get used to a new color scheme if it was temporary. I’ve liked all the defaults so far and this time is no exception.

Thanks for pushing out some fixes and a new stable release so quickly!

Multi Weather works fine in my case on 19. No error messages until today update to rc1. Now it seems to be fine too, but I’m getting error popup from time to time.
Can you recommend some weather addon compatible? It looks like MultiWeather is the only one that is compatible with Kodi 19 currently

[Edit]
I was wrong. Not working anymore, that was only cached data displayed. Gismeteo not working too. It seems rc1 update breaks all of them. They are compatible with Kodi Matrix

Gismeto works for me like a charme. You need to do a fresh install, it will solve almost every problem you have.

Hmm I’ll make sure to remove data folder manually. I am able to search and add location. But it fails on loading weather data, multi Weather same issue. I’ve been using both for a long time on 19.0, now on 19.1 rc1 both fail, weird.

Somebody mentioned to set English language, well not an option in my case

Will Matrix nightly’s now be based upon 19.1 rc1 as I noticed that the latest one of 20210325 shows 19.0 in the summary information?

The new nightlies are bases in Matrix are bases in latest stable that is Matrix 19.1-rc1. that information is correct because 19.1-rc1 is not yet 19.1.

1 Like

Works fine on X96 Air S905X3 Gigagbit on emmc. Thanks for all the effort

Something is with higher activity in background. Please check devices in idle through system information. In idle is going cpu on 23% - 51 % temporaly. I use only addon gismeteo for weather without issue. Maybe is problem with some check of upgrade of addons or etc. system function in background. Device: x88king

Can you run ce-debug and also post kodi log?

Neither MultiWeather nor Gismeto cause any trouble on my box. But my CoreElec is set to english. If you even made a clean install but restored some Leia Backup, it causes all kinds of trouble. Believe me, I did the same and paid the price.

1 Like

I agree, using a Leia backup mashed my SKIN in Matrix. Had to do a soft reset in the end.

Shoog

1 Like

Rc1 installation from scratch in a new SD.
UI seems more responsive now, but i have now an issue with live TV. It just sits there waiting for pvr to start. I need to disable TVH server and enable it again to watch tv.
What can I try, I mean, what has changed in this regard?
Thanks

Solved. It seems I went too far in restoring the old settings and copied service.tvheadend42.service to kodi.target.wants, but the system needs a symlink.

http://ix.io/2U4s and kodi.log (87.0 KB)

Checking your kodi log we can see there are some banned addons (check https://kodi.wiki/view/Official:Forum_rules/Banned_add-ons) and therefore no support can be given. Try a clean install and the problem persists please post a new log. But I can tell you that you have some nasty ones there, like Indigo, that probably are causing your problems. Maybe you now have a mining machine without your knowledge…

1 Like

On matrix 19.0 was not usage in idle. But i try clean install also on some other sd card.

No backup, upgraded. No problems on 19.0. Now on rc1 upgraded from 19.0 weather not working anymore, everything else seems to be fine.

I will try to make sure weather addons data is wiped, and if that does not help, try with English ui. But, if English ui is required (which was not on 19.0), it’s a bug

After all, weather is not most important functionality, but nice to have it

I tried to do a clean install of 19.1 rc1 on a VIM3. When I insert the sdcard and boot I get a blank screen. Does anyone know what firmware version is required for 19? I have 9.2.7 installed on another sdcard which is working fine.

This is a common problem. Try this workaround:

About | FAQ | Terms of Service | Privacy Policy | Legal Notice