CoreELEC 19.1-Matrix_rc1 Discussion

Just to wrap it up:
I found a firmware that works with all usb ports working and CE 19.1 being able to be intalled to internal memory.
For my Mini M8S II S905X Box I flashed this Android Version on it:
"MiniM8S_Oreo_8.0.0_By_Levy"
Other firmwares might work too, but I had to go through a few before I tried this one that finaly does its job.

2 Likes

I’m glad you found a working firmware! Congrats!

1 Like

In comparation on clean install is os many more worse. It was again more cpu usage than was on 19.1 compare to 19.0 in idle time. Also temperature on 19.1 had 52 c degree compare to 41 c degree on matrix 19.0 on my device x88king. High cpu usage is also in idle time on clear system after install of coreelec. Something is bad in coreelec, and also many times freezed in trying of restart whole device.

Can I make a suggestion for the dev’s, the strobing or flashing of the “CoreELEC” logo on boot is not a good idea as it could cause an attack of Photosensitive Epilepsy in sufferers, while not one myself I do have a female friend who suffers from it and it isn’t pleasant to have or to watch helplessly.

This may seem trivial to some people but its a genuine concern and probably the last thing you want from an A/V operating system / JEOS

I don’t see flashing of the logo. Just a gentle dim in and dim out. I though epilepsy is caused by fast changes like flashing on and off.

2 Likes

Hi,

Maybe this post would spare you from wasted hours trying to find a solution, but like me, I believe we learn new things. trouble with usb ports S905X SoC on Matrix
You could try to have the latest bootloader (Android 9) until devs will bake in the bootloader from new Android 10 boxes.

Can you provide the logs with the fresh install, please?

Yes, but also i have some installed yet addons in this time: http://ix.io/2UrR
Failed logs in kodi, but here is second option from menu of logs with many errors: http://ix.io/2UrV

One of them is Gismeteo. I would bet this is the culprit. Delete it (with data), try again and your cpu usage should go back to normal.

You have lots of errors with the moviedb. Please check your settings in that addon or do a clean of the library and start over

I tried uninstall a delete data and restart of device. Always is same cpu usage after start 25-30%. It is something other than gismeteo.

Try disabling all addons, reboot and check then. If it’s then OK, enable one by one until you find what’s causing high CPU usage.

I found now solution, but i will tested more hour with watching iptv. I changed cpu governor from ondemand to performance and now is cpu less used in idle and normal time. I will check temperature. From kodi 19.0 i dont see frequence in kodi.

Try to SS to the box and run:
cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_cur_freq

Ok, in ondemad is jump from 667 to 1704 in idle time. I really try again from zero ckean install. Disabling of addons not helped.

It will be good some ssh utility for monitoring of proceses in backroung and cpu usage

Try the command top

yes, …kodi.bin use 23,5 %

I use netdata webgui

Conclusion: is not addon. I installed again coreelec, changed cpu gouvern from default performance on ondemad, and cpu usage is 23+% in idle (in coreelec 19.0 it was max 10 % in idle). It is bug of used kodi in coreleec, if kodi.bin have high cpu usage.

http://ix.io/2UCi
http://ix.io/2UCo
http://ix.io/2UCn
http://ix.io/2UCl

For compare, logs from 9.2.7:
http://ix.io/2UCt
http://ix.io/2UCs
http://ix.io/2UCr

  • Test was on same sd card. Here are diferencess with ms word created (small my fault: i forgot enabling of wol and saved config file of remote config on sd card on 9.2.7 system, therefore is as something “new”, but dont have impact on results) : CoreELEC Debug Information_diferences.docx (53.5 KB)

About | FAQ | Terms of Service | Privacy Policy | Legal Notice