CoreELEC 19.1-Matrix_rc1 Discussion

If you use the search in forum you’ll find many users that updated the firmware of various different devices. That has been our answer many time, update firmware. It’s impossible to cover all devices and sometimes users have to be a little more proactive in finding the solution that fits them.

1 Like

Well updating my firmware was the first thing I did.
The problem was that the latest official firmware for my device is from 2017.
The ROM I used is custom made but hey, if that does the trick who cares.
Just wanted others to save some trouble by making my discovery puplic.
It could have saved me some hours of my life had I found a report like this anywhere on the net.

Thanks anyway. At least it lead to something good.

And we thank you for that because others will search the forum and find your post with the answer they’re looking.

Next topic,
anyone experiencing problems with their usb ports?
It seems like my rear usb port doesn’t work anymore after the switch to CE 19.1. The on on the side of the box still works like a charm.
Maybe its a problem that came with the custom ROM I used earlier but shouldn’t the ceemmc tool have overwritten everything from the Android Firmware?

Edit: It realy was the fault of the ROM and its bootloader I was using. I’ll try some different ROMs out and be back if find a fitting one.

No, it still uses the bootloader and you should have confirmed how everything worked with android just to see if that was the adequate firmware for you.

1 Like

Good evening, I am an owner of Odroid N2, I have installed kodi19.1 Matrix, everything works but an option that I liked a lot is missing, it is located on the home skin settings and it is “hide to cinema / movie coming out” on kodi Leia was present now she is gone. It is a bug or it is activated with some addon incompatible with this version. Thanks.problema kodi.bmp (4.9 MB)

The nightlies are running spectacularly on my x96 S905x box. I’ve noticed, however, that the update progress dialogue is no longer shown at the splashscreen in CE 19. I’m guessing this is intentional and honestly gives everything a much cleaner look.

Is there a setting buried in a startup script that I can manually add/modify to have that dialogue displayed?

The reason I’m asking is because others in my home have suddenly decided to start using the “nightly” testing box again and I’m sick of answering questions about whether the box has stalled at the boot screen.

Hey guys I flashed this to emmc on my odroid c4, all working lovely although menu colours seem a bit washed out, is this normal? Getting surround sound working with my sonos beam is tricky, is it just not ready for all files yet? Some are fine, some no voice audio, I’ve changed to 5.1 out rather than 2.0 like we used to… I’m primarily setting the box up as an emby server which it seems to do fine. I need add transmission and other services but just wanted check the basics first.
Are there just some audio driver glitches? I don’t mind stick with it I’ve got other boxes to wat h on. As this is odroid I figure support should be reasonable, just wondering state of play really, maybe I could start helping somehow.

The skin default has been changed to teal, so the washed out look is correct. You can change the colours using Theme in Settings/Interface.

1 Like

Just to wrap it up:
I found a firmware that works with all usb ports working and CE 19.1 being able to be intalled to internal memory.
For my Mini M8S II S905X Box I flashed this Android Version on it:
Other firmwares might work too, but I had to go through a few before I tried this one that finaly does its job.


I’m glad you found a working firmware! Congrats!

1 Like

In comparation on clean install is os many more worse. It was again more cpu usage than was on 19.1 compare to 19.0 in idle time. Also temperature on 19.1 had 52 c degree compare to 41 c degree on matrix 19.0 on my device x88king. High cpu usage is also in idle time on clear system after install of coreelec. Something is bad in coreelec, and also many times freezed in trying of restart whole device.

Can I make a suggestion for the dev’s, the strobing or flashing of the “CoreELEC” logo on boot is not a good idea as it could cause an attack of Photosensitive Epilepsy in sufferers, while not one myself I do have a female friend who suffers from it and it isn’t pleasant to have or to watch helplessly.

This may seem trivial to some people but its a genuine concern and probably the last thing you want from an A/V operating system / JEOS

I don’t see flashing of the logo. Just a gentle dim in and dim out. I though epilepsy is caused by fast changes like flashing on and off.



Maybe this post would spare you from wasted hours trying to find a solution, but like me, I believe we learn new things. trouble with usb ports S905X SoC on Matrix
You could try to have the latest bootloader (Android 9) until devs will bake in the bootloader from new Android 10 boxes.

Can you provide the logs with the fresh install, please?

Yes, but also i have some installed yet addons in this time:
Failed logs in kodi, but here is second option from menu of logs with many errors:

One of them is Gismeteo. I would bet this is the culprit. Delete it (with data), try again and your cpu usage should go back to normal.

You have lots of errors with the moviedb. Please check your settings in that addon or do a clean of the library and start over

I tried uninstall a delete data and restart of device. Always is same cpu usage after start 25-30%. It is something other than gismeteo.