CoreELEC 19.1-Matrix_rc1 Discussion

Where do I put the autostart.sh file on the sdcard before installing?

Into .config/Configfile. What do you mean ‘before installing’?

Usually you get a weird colored screen (pink, mint, teal, magenta …), if your tv is powered on after your box is. Then your box can’t read EDID on start. Therefore aforementioned Autostart comes in play and forces Kodi to switch once the resolution.

If your box doesn’t even boot properly, you have an entirely different problem.

You don’t need “autostart.sh” file for installation; just install fresh image and if initial screen is not shown, wait for a couple of minutes for installation to finish. Then you should see Kodi Home screen.
If the installation does not finish, then there is some other problem that “autostart.sh” cannot fix, as far as I know…

Greetings!

Sorry for my poor english,its not my native language.
And sorry if wrong thread…
My question is:
CE 9.2.7 NG works well with my S905X box…
Is CE 19 Matrix compatible with my box?
Im not really understand the details.

Unfortuanteley - as mentioned on CE19 thread too - I still got stuttering problems with H264 videos on my Mecool KI Pro box /S905D). I can narrow it down to H264 as once I set the hw acceleration of H264 to “never” the stutter is gone…I could live with that but then the main problem on some HD channels is that the framerate is drastically cut down like if it is at ~5fps. Unsure what causes this. Logs had been posted in CE19 thread. Don’t know what else I can do to help fixing this?

Yes. Both run on the 4.9 kernel, your box should run fine with Matrix. But to be safe, use a new SD-Card at first. Then you can test the heck out of Matrix. If it doesn’t satisfy you, then change back to Leia.

Many thanks and best regards!

@byomi What add-on do you use for Sky Germany? Is there a one that still works?

I can cofirm that CE 19.0 Matrix runs on my Mini M8S II S905X box.
But only from SD-Card or USB stick.
I tried to port it to the internal memory using the CEEMMC tool but after that my device was bricked.
I know it’s not on the list of officialy supported devices but I hope one day it will be because CE runs far better on the internal memory for me. That might be because of my slow USB stick but I’don’t want to buy a new one just for that purpose.
Until then I’ll stick to the Legacy builds.

What did you have in internal when you tried cemmc?

I used ceemmc with the first CE19 release on March beginning. After running it my Mecool KI Pro box was bricked and I needed to open it and locate the points on the chip to get it reflashed again with Amlogic tool. So be cautious trying that. But I am still interested in it to be able to abandon my sdcard. I chosed to replace the ANdroid partition and tried to use the full memory for CE. Maybe that was my fault and I should have been chosing the option to keep it with Android datat? I read that CE19 RC1 has some changes regarding for ceemc but unsure if I should retry again…

@ Vasco: At that time I had CE 9.2.6 in my internal.

@byomi: I tried the dual boot option too afterwards. Same result.

To use ceemmc you must have android in internal. You may try again but always be prepared for a recovery operation.

1 Like

Ok understood that with ceemc. Maybe try again later once I solved the problem with video playback (stutter / jiddder). Tried to play Minions films while log. As stated earlier the stutter / jidder is solved when disabling h264 hw acceleration but then I get low framerate playback on HD channels in IPTV simple client and that’s no solution. Never had problems on CE9.2 (non-NG). Here are my logs:

CE-debug:
http://ix.io/2Uf1

Log (Stutter / Jidder with VideoPlayer::OpenFile: /media/sda1-usb-SanDisk_Ultra_US/Minions (Hd).mkv):
http://ix.io/2Uf2

Test-Video:

Edit:
This forum user has the EXACT same problem. Tested his file and it is identical issue:

Thanks for the logs. Can you share a small sample of the video like 30 sec or something like @boot2k3 asked in the old thread?

OK now I flashed my device back to Android but when using ceemmc I get following message:

Install in single boot mode not possible!
No DT partition was found

last time I could choose between all 4 options. Do I have to do something in addition?

Your device/firmware is just to old. Buy a newer device or just use dual boot. This limit was introduced with a reason!

I just updated my previous post with a testvideo so we got everything in one place. Let me know if it stutters for you too?

Trying dual boot results to this:

Please choose one option? [1/2]: 1

Aborting!

So neither option is really availible for my device. The Legacy builds will have to suffice then.

Ha!
As discouraging your reply was it gave me an idea and it works.
I saw a youtube tutorial " How to flash [ROM] ATVXperience on Mini M8S II (p212 board, S905X)".
It’s an Android 9.0 firmware running on the same kernel CE 19.1 Matrix does.
After flashing my box with it I ran ceemmc again and it worked.

Maybee you could post that somewhere in a tutorial so others with the same problem will find their solution quicker than me.