Coreelec 19.2 on Scishion v88 Pro (Amlogic S905X)

Hi, and first of all thanks for all your work.
I have a Scishion v88 Pro box with Amlogic S905X and 1 GB RAM.
Everything works booting from SD Coreelec legacy version 9.28.
I tried booting from SD the new version 19.2 using DTB gxl_p212_1g (as I did for the old version):
it seems that linux is booting correctly (I enabled ssh con config.ini and I was able to collect the dmesg log https://pastebin.com/UVvmsFzp), but as soon as kodi starts the box hangs and eventually reboot (I also collected a log from the kodi startup https://pastebin.com/AgHZm3f3)
Do you have an hint on how to solve the problem?
Thank you
Alex

Hi everyone,
I tested also the new version 19.3 booting from SD, but the result doesn’t change: linux boots correctly, but when kodi starts the box hangs and, after a few seconds, reboots.
So, unless anyone has some hints on how to solve the problem, I think you should remove this box from the list of supported device for amlogic-ng builds: the advice is to stick with the legacy version 9.2.8 which I installed on internal eMMC and it’s working perfectly.
Thank you

Can you bite the bullet for last time? Try the 19.4_RC1, if not, than yes, Leia forever.

Your log is full of SD card access errors. That is why at some step you have issues.
Try with another card. For some devices cards <= 8GB could be better.

Hi everyone,
I followed your hints and try to boot the 19.4 nigthly build using a 2GB SD card.
The results are the same: linux starts correctly but as soon as kodi starts the box hangs and reboots after a few seconds.
Here are the logs: dmesg kodi.
Unless your find something useful in my logs, if there is no way to get more logging from kodi to understand where it hangs I guess there is nothing that we can do to make this box work on the new -ng builds.
Thank you

Minimum Android 7 on the box?

I installed CE 9.2.8 on eMMC, so I can’t check the original Android version, but I think it was version 6.

Hmm, you need to flash a bootloader at least Android 7 so you can get ng builds properly.

Start from here: Testers wanted: GXL, 1GB RAM devices, Amlogic-ng

Hi everyone,
I have now a working CE 19.3 installed on eMMC in my box, but it was not simple to get there.
Here are the steps:

  1. I first flashed Aidan’s Android 7.1.2 TV rom v8 to upgrade the bootloaders.
  2. I download and install the app “Reboot to libreelec” on android to be able to make the box boot from sd
  3. I booted the box from SD with CE 19.3 and it worked
  4. I used the ceemmc tool even if the box was not supported: I was forced to try a dual boot install because the tool reported:
    Install in single boot mode not possible!
    No DT partition was found
    but the operation failed:
    e2fsck 1.45.7 (28-Jan-2021)
    Error running pclose on cmd: e2fsck -fy /dev/loop3. Error: 1
    Error executing cmd ‘e2fsck -fy /dev/loop3’
    Failed to resize partition ‘CE_STORAGE’!
    Rebooting the box android started but it was corrupted and I had to reflash the box with Aidan ROM and repeat all the steps.
    The second time I run the ceemmc tool twice: the first time gave the same error as before, the second time I choose to the option ‘Migrate CoreELEC dual boot to single boot installation’ taking Coreelec data from the SD
    On reboot Coreelec 19.3 started from eMMC at last!
    It was a pity that the ceemmc tool couldn’t setup a dual boot with CE 19.3 and the Android Aidan ROM that was working well, but I guess I can say I’m happy to have now CE 19.3 working on my box
    Thank you
1 Like

Glad to hear you still have a working box! Could try to get ATV Experience based on Android 9. Maybe that would allow dual boot.

About | FAQ | Terms of Service | Privacy Policy | Legal Notice