CoreELEC 19.4-Matrix_rc2 Discussion

@MrNice, I don’t see something specific in log.
It’s Denon Receiver and we couldn’t do something with it as no way to repeat.

  1. HDMI splitter
  2. To try for GUI different refresh rates and resolutions (1080p or 2160p)


I’ll try GUI resolution, frequency and let you know

Hi boot2k3,
As I said, I did lot of tests to find a fix the resolution/sync frequency issue at start/stop playing.
At 1080p from 23.98 to 60, 3840x2160 23.98 to 30, screen never sync at start (black) but always good at stop (menu image).
At 4096x2160 23.98 and 24 sync is good at start and at stop !!! :grinning:
However when playing the test file jellyfish HEVC, HEVC10 and H264 from 160 to 3 mbps, there are jerk about every second. :worried:
Please find the log, could you have a look

If your GUI resolution is bigger than video resolution then you need to select all 1080p and 2160p whitelist resolutions and refresh rates you are going to use

Hi all

Since the 19.4 RC2 update, or at least I noticed this since the update - All of my GT King devices have a weird issue running the interface at 4k - The text looks slightly blurred and seems to be made up of scan lines - 4K video plays without issue, but all interface elements have this (including OSD when I pause for example).

As soon as I set the interface to 1080p it’s fine (although OSD is affected when playing a 4K video).

Has anyone else had this? I’ve just set the interface to 1080 for now and it’s not exactly a dealbreaker…was just wondering if there is anything I can do to resolve.


1 Like

Please before report issues try first nightly version if it is already fixed, thank you.

I’m not really comfortable with running nightlies…I have had issues with them in the past…which is why I just asked if anyone else had seen this issue.

Tracking issues is a kind of process with including the step to try first last nightly if the issue is may fixed already. Or using the search function or reading the thread would have shown the issue was fixed already some days ago.


I tried the whitelist with a part of disp_cap file and the 2 settings just bellow. Unfortunately, no improvement still the jerking about every second in the test files jellyfish.
But… when I play the films there is no jerking at all. :smiley:
I tried lot of time and the start/stop are good 9 times over 10. This is the best setting I found.
Thanks for you help

OK, I’ll download a nightly build, then, and try it on two different SD cards (to eliminate the SD as a point of contention) and report back.

Because I too am getting the ‘scanlines’ issue. Also, testing with the leviathan.m2ts file (that I mention here) from Dolby Trailers on TDT, causes video and audio issues of some kind every single playback.

For the record, I’m not posting the previous, or the following, as any kind of gotcha or complaint. Purely as a record or information on what I’ve tested and what ancillary eqipment that’s involved is proven to be OK.

Using 3 different (1 48G, 2 18G) certified HDMI cables, on the N2+ and then on a pi4 with a nightly build, the pi4 plays back the file flawlessly in HDR (possibly HDR10). I realise that there are different chips, and base OS’ involved here, again, this is purely to indicate AV capabilities and any issues with the file.

If you use passthrough for Atmos audio then it should work flawless.
If you don’t use passthrough then choose another codec. Some TrueHD without passthrough can cause crash on kodi.

I can’t tell if this was in response to me, but it doesn’t look like it.

All the same:

  1. I linked a separate thread for my issues.
    So, I’ll not poison this thread discussing them. :sweat_smile:

  2. I do, and it is not flawless. :wink:

Happy to discuss over in the thread, though. :+1:

I’m experiencing stream interruptions when watching Live-TV on my N2 on a regular basis now. The stream stalls for a couple of seconds, and then resumes.

Kodi log:

Any advice appreciated.

1 Like
2022-02-11 20:44:09.699 T:3937     INFO <general>: CVideoPlayerAudio::Process - stream stalled
2022-02-11 20:44:19.167 T:3936  WARNING <general>: AddOnLog: pvr.hts: demux read no data for at least 10 secs; restarting connection

Looks like some stream, connection or pvr.hts issue

There is the same problem.

1 Like

Hmh, you run a different CE version there. But we may look for commonalities:

  • I use an “early” N2
  • I run TVH in Docker
  • Both run on an OMV server
  • I use Emby with the Emby next gen addon
  • My network components are from Ubiquiti

Is there anything similar with your system?

There is the same problem with Coreelec matrix.

no, it looks different.

Kodi log:
Dmesg :