CoreELEC 19.5-Matrix_rc1 Discussion

Need some help, i updated my X96mini S905W 1GB/8GB, to the 19.5-rc1 today and noticed that got no audio to the TV from any stream, runned the emuelec addon and got audio without problem, returned to 19.4 and got the audio back.

Keep the good work

Same issue here: The update stopped audio output to HDMI. A workaround which worked for me was to change audio output from HDMI to PCM in System settings (while still keeping the TV connected by HDMI… So this setting is clearly wrong but as I said: It’s a workaround to get audio back).

1 Like

Thanks for the workaround, but i’ll wait for rc2 and see if its fixed, until then 19.4 is going to be my daily driver.

I had this issue too, but after I changed the output options in the settings it started working.

S905W : No MP2 audio with 19.5rc1 via HDMI - ACM 2ch and 5ch is fine.
Setting audio passthrough on/off or changing any other setting makes no difference.
Rollback to 19.4 brings MP2 audio back.

@all No reports about the “no audio” are needed anymore. We found already the location about the issue but have no fix for it yet.

Workaround should be to change the audio device to PCM in Kodi audio settings.


I have tried all and everything wifi on these devices and gave up. Never reliable…

This (Kodi crashing on SD-HD change) is now officially non-related to 19.5rc1.
Have been able to reproduce on 19.3. Just takes longer to trigger…

Tanix TX7 S905x box been working fine in CoreELEC 19.4 but now updated to 19.5 rc1 and no audio. I tried this also on a friends same type TX7 box and the same result of no audio after the update. Reverted back to 19.4 and audio returns. Just reporting a bug so staying on 19.4 for now

reading before posting…

The issue with no audio on GXL devices is solved. Please update tomorrow to 20220505 nightly and the issue should be solved.

Or you switch temporary the audio device to PCM in Kodi audio settings until 19.5-Matric_rc2 is released.


I have a hard time believing that the skin would allow a 5ghz wifi connection to be established, but cause a 2.4ghz connection to fail.
However here are logs using the default skin.


Changed skin to default
Tried to connect to 2.4 GHZ WiFi. Failed without error.
Attempting to connect to 5GHZ crashed the Coreelec add-on if done directly after attempting a 2.4 connection (I bet the add-on crashing is where you saw the skin error coming from). If I attempt a 5GHZ connection without trying 2.4 first, it connects without issues.

The issue still persists with the default skin.
Just for S&Gs I tried the 5-3 nightly, and it has the same issue.

Any other ideas? I still think there is an issue with the module being used. Does anyone know how old it is, or where it was obtained? Maybe there is a new one that fixes these issues.

Any other thoughts?

The Audio issue is in the log:
“2022-05-03 21:40:37.832 T:3479 DEBUG : CAESinkALSA - Unable to obtain ELD information for device “hdmi:CARD=AMLMESONAUDIO,DEV=0” (not supported by device, or kernel older than 3.2)”
Switching to PCM resolved the issue.

You need to be more specific about the scenario and include logs. First you posted “SD is being watched through the PVR recording section and user starts a HD recording” I took that to mean starts a recording but you told no me it was “SD recording is played when selecting an HD recording” so I guess you mean start playing an SD recording and while it is playing start playing an HD recording without stopping. I have tried this with pvr.nextpvr and again no issues.

Thanks you so much. Your work is excellent. Yes I noticed by switching of the Meson HDMI audio output to the analogue or PCM it all worked albeit without the better quality digital passthrough audio of course.

Try again with clean install WITHOUT any addon or modification. Kodi is crashing, no idea why and I am almost sure it’s related to one of your addon installed.

Now checked it out and can report that the nightly works fine with the audio now back on my old TX7 box. So once again many thanks

1 Like

Point taken, i’'ll try and be more specific.

Tried to get the debug info for half an hour starting recordings (SD->HD->SD etc).
Weirdly enough, the issue does not occur at all while in debug mode. Turned off debug mode and it happened within the first couple of tries.

This is what the crashlog said:

2022-05-03 22:03:36.758 T:4958     INFO <general>: Display resolution ADJUST : 1920x1080 @ 50.00 - Full Screen (16) (weight: -270675410944.000)
2022-05-03 22:03:37.397 T:5121     INFO <general>: CActiveAEStream::AddData - messy timestamps, increasing interval for measuring average error to 2168 ms
2022-05-03 22:03:38.054 T:5516    ERROR <general>: GetDirectory - Error getting 
2022-05-03 22:03:38.074 T:5060     INFO <general>: AddOnLog: pvr.dvblink: Found 63 recordings
2022-05-03 22:03:38.837 T:5516    ERROR <general>: DoWork - Direct texture file loading failed for special://masterprofile/Thumbnails/9/9999393d.jpg
2022-05-03 22:03:39.217 T:4958     INFO <general>: [WHITELIST] Searching the whitelist for: width: 1920, height: 1080, fps: 50.000, 3D: false
2022-05-03 22:03:39.218 T:4958     INFO <general>: Display resolution ADJUST : 1920x1080 @ 50.00 - Full Screen (16) (weight: 0.000)
2022-05-03 22:03:39.247 T:4958     INFO <general>: VideoPlayer::OpenFile: pvr://recordings/tv/active/Doctor Who/Doctor%20Who (1969), TV%20(BBC%20One%20HD), 20211205_182004, 8F94B459-EFC0-4D91-9B29-EC3D72E92677:F6F08949-2A07-4074-9E9D-423D877270BB/7-13576733226387993080-1638728400.pvr
2022-05-03 22:03:39.256 T:5896  WARNING <general>: OutputPicture - timeout waiting for buffer
2022-05-03 22:03:39.256 T:5516     INFO <general>: Deleting settings information for files pvr://recordings/tv/active/Doctor Who/Doctor%20Who (1969), TV%20(BBC%20One%20HD), 20220101_190004, 8F94B459-EFC0-4D91-9B29-EC3D72E92677:F6F08949-2A07-4074-9E9D-423D877270BB/7-13576733226387993080-1641063600.pvr

############### END LOG FILE ################

############ END kodi CRASH LOG #############

No idea why its looking for a whitelist (not using it) or why things would stall in a high speed local network. And any issue with playback should never crash Kodi imho.

Next step is try TVHeadend to rule out TVMosaic,

Well this is interesting, after using a 100% unmodified install. There is no WiFi at all. No 5GHZ, no 2.4. Nothing at all.
Tried rebooting after the initial install. Still no WiFi connections available.

For the record this is an A95X (S905x) box.

Logs (via wired ethernet):


It’s not very important for me, but with version 19.5 rc1 I see this message with ssh access:

CoreELEC (official): 19.5-Matrix_rc1 (Amlogic-ng.arm)
-sh: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)

I think that I did NOT see that with 19.4 and it started after upgradint to 19.5 rc1. I’m not absolutely sure about this.

I’m using entware, too, with a X96 Max+ (S905X3).