CoreELEC 19 Matrix Discussion (Kodi RC)

Interesting. Initially I had an issue like that - I had a left over line in config.ini setting 1008p60Hz as the HDMI mode (from previously trying to solve an issue with black flickering with 4:4:4 signals).

With that in, I realised I was only seeing 60hz modes available (so playback at 60hz, and in the list of available resolutions in the Kodi GUI). Even the disp_cap was only showing 60hz options at that ppint.

I took that out and rebooted and then all was well again, with all those rates above visible by catting disp_cap and in the Kodi GUI.

One thing I didn’t do was check, when seeing this particular issue, that (for whatever reason) these refresh rates were still available in the Kodi GUI.

Like I said, more testing needed. And yep, a full log…

I am experiencing something similar. When I start my TV after my Y8 max, Settings, System, Display shows Resolution of 1280x720 and 60 Hz refresh rate. Instead 1920x1080/50Hz which is the usual setting. When this happens, sometimes 25 fps content is played with 60 Hz instead of 50 or content with 29,97 fps is played with 24 Hz. So it jitters.

If I correct Settings, System, Display to the usual 1080p50, frame rate switches to the correct value.

It took me a while to notice this. So I usually power on my tv first, then my box and everything is fine.

I use a Harmony remote, it starts TV, then amp, then Kodi box, in that order…and has done for 15+ years or so (with a variety of TVs and amps along the way of course).

I will test more and experiment with actually saving a disp_cap in userdata which I believe is the fix for these sorts of things…giving the Kodi box (Odroid N2) - an explicit list of modes so it should therefore always pick that up I guess.

No, I use the regular 9.2. Where can I find that matching dtb? is it in my box?

Yes, this is correct. And it will solve the issue for most other users to.

The CE device does read the EDID form the TV and some TV do not provide it when turned off. So the CE device does set an default resolution as it does not have the TV EDID information.

So the rule is that the TV needs to be on before the CE device get booted!

I believe cat /sys/class/amhdmitx/amhdmitx0/disp_cap > /storage/.kodi/userdata/disp_cap would deserve some GUI element for it in skin or something. Its just a MUST to everyone with box running 24/7, not only for those with AVR without offline passthrough.

I remember disp_cap was like a big relief, when I searching replacement for Rpi’s exported EDID. Every basic restart (for update, or just some regular stuff like electric outtage) is really pain without stored EDID information for 24/7 boxes.


Is anyone running a setup with NFS connected video sources? It worked before but became unusable at least for me because of heavy stuttering.

1 Like

I have multiple NFS sources from multiple machines attached to my N2. I upgraded to the new stable 19 the other day. I’ve only watched some old SD resolution shows I’ve been binging. I haven’t noticed any issues. I’ll try some bigger heavier 4K type stuff tonight to test it out.

1 Like

In case you won’t see any problems with HD content can you share your NFS server share options from /etc/exports please?

I use NFS extensively. No issues with Matrix and this includes up to 65Gb 4K/HDR remux type files.

I am using Hanewin NFS server on a Win10 machine, and a typical export looks like:

"L:\TV Library 07"  -name:TVLibrary07 -alldirs -maproot:0 -mapall:0

I watched a 73GB movie and had no issues. I watched the screen stats occasionally and it said 0 drops or skips.

I have a CentOS7 server on standard GB networking.

The usual NFS exports look like this:


Ok, installed Matrix in a card with the correct dtb and it boots, but then I can’t advance in the wizard because the remote doesn’t work. What can I do?

Still no issue __vpeter build.

Matrix 19 stable has the issue switching to 480p on reboot, not every time.

__vpeter test build no issue yet. :+1:

1 Like

Thank you for testing. Patch already included in 20210304 nightly build.


Use a usb keyboard

Thank you, a good joke is always welcome :roll_eyes:

Please explain. What was the joke?

You use an usb keyboard to get past the first part of config and activate ssh. Then you can ssh to the device and configure your remote.

It makes sense now, but I never had to configure the remote before. I was hoping that I could edit some file in the card to make it use my remote (the original)