CoreELEC 20.0-Nexus_alpha2 Discussion

Please use this thread for general 20.0-Nexus_alpha2 discussion

Before posting an error please follow these troubleshooting steps.


Is it possible to fix the problem whith the samba connection in Kodi20
I cannot connect to the home directory like in Kodi19

Not yet - you need to specify the folder.

1 Like

CE Nexus latest nightly immediately freezes and goes into bootloop when IPTV Simple Client is installed. I tried this on both Windows and CoreELEC so I rather suspect the fault lies with Kodi and not the add-on.

For me only Kodi crashed and restarts. But only if I try to play something from it.

Looks like the issue happens with gnutls bump - 3.7.6 works fine according to my tests.

Is there are known issue in this alpha with streaming h264 live TV with amcodec on the original N2 and S902X4? I just get a black screen during playback and unsupported stream log messages. With software decoding I do get video. My HDHR transcodes and using mpeg2 mode the same channel is fine with h/w playback. Recordings from these streams work fine too even in-progress.

I think it did work in alpha1 (or some earlier self builds) but the archive doesn’t go back that far for me to confirm

I use it with live tv every single day without any problems but you need to provide logs to see what’s happening.

Here are a log of a couple of Live TV failures, followed by a successful playback of an in-progress recording. As noted mpeg2 video is fine.

For reference here is 19.5 rc2 A different box but 19.5 works on the S905X4 too.

I use S905x4 and everything is working fine (TV via TVH, streaming via Emby)

Recently started to use AVR with passthrough from STB->TV->eARC->AVR, works fine

I found problem with CE after switching audio source in the AVR from TV to AirPlay or other sound disappear in the STB.

2022-08-19 11:45:26.100 T:3721     INFO <general>: CActiveAESink::OpenSink - initialize sink
2022-08-19 11:45:26.107 T:3721     INFO <general>: CAESinkALSA::Initialize - Configure simple control for "AUGESOUND"
2022-08-19 11:45:26.145 T:3721     INFO <general>: CAESinkALSA - Use card "hw:0" and set codec format "2 CH PCM"
2022-08-19 11:45:26.228 T:3721     INFO <general>: CAESinkALSA - Set Spdif to HDMITX to "Spdif"
2022-08-19 11:45:26.228 T:3721     INFO <general>: CAESinkALSA - Set codec for "Audio spdif_b format"
2022-08-19 11:45:26.228 T:3721     INFO <general>: CAESinkALSA - Set codec for "Audio spdif format"
2022-08-19 11:45:26.228 T:3721     INFO <general>: CAESinkALSA::Initialize - Attempting to open device "surround71:CARD=AMLAUGESOUND,DEV=0"
2022-08-19 11:45:26.250 T:3721     INFO <general>: CAESinkALSA::Initialize - Opened device "surround71:CARD=AMLAUGESOUND,DEV=0"
2022-08-19 11:45:26.253 T:3721     INFO <general>: CAESinkALSA::InitializeHW - Your hardware does not support AE_FMT_FLOAT, trying other formats
2022-08-19 11:45:26.254 T:3721     INFO <general>: CAESinkALSA::InitializeHW - Using data format AE_FMT_S24NE4
2022-08-19 11:45:26.305 T:3721    ERROR <general>: CAESinkALSA - snd_pcm_writei(-32) Broken pipe - trying to recover
2022-08-19 11:45:36.520 T:3721     INFO <general>: Skipped 15 duplicate messages..
2022-08-19 11:45:36.520 T:3721    ERROR <general>: CAESinkALSA - snd_pcm_writei(-32) Broken pipe - trying to recover
2022-08-19 11:45:46.885 T:3721     INFO <general>: Skipped 29 duplicate messages..
2022-08-19 11:45:46.885 T:3721    ERROR <general>: CAESinkALSA - snd_pcm_writei(-32) Broken pipe - trying to recover

AirPlay is a “hack” and never worked fully I think.
It’s a know Kodi issue for long time and won’t be solved in future I guess.

Hint: don’t use proprietary hardware with proprietary software. If the vendor change a minor bit all stop working again.

Is there anything more from the longs I need to provide other then this CoreELEC 20.0-Nexus_alpha2 Discussion - #12 by emveepee

In this log I started streaming Live TV from the device to another client and played the temp buffer that NextPVR creates and it played from the file system so I don’t think it is the source Is there are way to use “hints” like 19.5?

Please try on other midroSD or USB stick a clean install of Nexus Alpha with only the minimum required addons to play the stream. In 19.5 you don’t have any problems?

Ok, here is the N2 which experiences the same problem Two failed live TV attempts, a successful play of an in-progress recording on the second channel, and finally live tv working with h264 h/w acceleration disabled.

The 19.5 log I posted above is on this box show it working

Kodi Nexus is Alpha status.
So any issue must be checked before posting by the user if it happens also on other platforms like Windows or Linux like Ubuntu.
If yes please go directly to Kodi GitHub and open there a issue as it’s not directly related to CoreELEC.
If the issue happen only on CoreELEC platform please feel free to ask if someone can help, thx.

My Nexus issue I am having seems to be specific to the CE Amlogic h264 detection. I have tested on LE11 with Generic, Amlogic N2, RPi4, and Rockchip 3566 builds. Here is the LE11 N2 log with h/w decoding showing it working. There is brief pixelation at the start.

For background I have been testing the install of a standalone LE/CE package for the NextPVR backend and have tried multiple times on S905x4 and the N2. It fails from remote backends too. If there is any other test you can think of let me know. I have a Vim3L

Sorry, LE is no reference as it use completely another kernel. Try with Windows or Linux Kodi so you can see if it’s a Kodi issue or platform issue?

And if think it’s the h264 decoder upload a short sample that we can take a look into it.