CoreELEC 20.0 Nexus aml-vnc default password no longer authenticates

Hi all - I recently upgraded from CoreELEC 19.5 to 20.0. The aml-vnc addon no longer allows me to authenticate using RealVNC or any other VNC client for that matter.

The password is unchanged looking at /storage/.kodi/userdata/addon_data/service.aml-vnc/settings.xml

RealVNC gives me a ‘Password check failed’ when attempting to authenticate. I have tried setting an alternative password and restarting the aml-vnc service to no avail.

Any ideas what changed?

Kind Regards

Chris

Update to latest nightly where addon is fixed or install this version manually.
https://relkai.coreelec.org/addons/Amlogic-ng/20.1/arm/service.aml-vnc/service.aml-vnc-20.1.0.zip

1 Like

Hello:

After upgrading from 19.5 to 20.0 (S905X3, ng), aml-vnc did NOT work.

I tried to install manually this:
https://relkai.coreelec.org/addons/Amlogic-ng/20.1/arm/service.aml-vnc/service.aml-vnc-20.1.0.zip

And, only upgrading the addon, it still did NOT work.

Then, I removed the add-on and its settings, and after that, I installed:
https://relkai.coreelec.org/addons/Amlogic-ng/20.1/arm/service.aml-vnc/service.aml-vnc-20.1.0.zip

After that I configured the amlc-vnc add-on (changed default port, changed password using the add-on settings interface, etc.), and, after deactivate - activade the add-on, it works perfectly well with edited port and password.
But… it seems that it is necessary to remove the “old” add-on (and perhaps its settings) first.

Thanks again, @vpeter , and kind regards