CoreELEC 20.2 for Radxa Zero2 does not recognize SD card storage

Hello Experts, I am having an issue with my CoreELEC 20.2 install and hoping to get some help. For some reason, it does not seem to recognize my exFAT formatted SD cards when inserted into my Radxa Zero 2 16GB EMMC. I have followed Radxa’s instructions to use my Windows PC to install CoreELEC (any linux iso) onto the embedded storage, but when I launch CoreELEC for the first time, and get into the OS, I cannot access my SD cards. They do not show up as a source. I do not have this problem on my Raspi4 or my original Radxa Zero with EMMC. If Insert an SD card, it shows up right away in those devices. I have tried several known-working SD cards formatted them as exFAT, and none of them show up, but they work in other devices. I have also installed Armbian Jammy 23.11.1 to my Radxa Zero2 and that OS sees the SD card storage, so I know the SD cards work, and the storage slot isn’t damaged, so I am thinking my issue is with the CoreELEC install? Any idea how I could trouble shoot this, or is it possibly a known issue?

https://wiki.coreelec.org/coreelec:ce_support

1 Like

Is it possible to mount my SD card manually via command line? I was able to ssh to the Radxa zero2 running CoreElec 20.2 but running fdisk was not found, and my limited linux knowledge did not work :slight_smile: I am used to my SD cards showing up in CoreELEC/LibreELEC automatically.

To troubleshoot further, I installed Armbian back on the Radxa’s EMMC and used gnome disks util to mount my SD card, and then after installing Kodi, I could then play a movie file from the SD card in Kodi. However my HDMI-CEC remote was not working with the TV, so I think getting CoreELEC to mount the SD card is cleaner and better option.

Apologies, what about the document? It’s a big one. I tired to upload the log bundle and it failed on “Pasting…”


Please see screenshots uploaded attached. The first is when the sd card is inserted into an sd card reader adapter by way of USB OTG cable connected the usb-c port on the Radxa Zero 2, we can see it shows up as /dev/sda1. The second screenshot is when I have the micro sd card inserted into the onboard slot. It’s like CoreELEC is not recognizing or mounting the sd card when inserted into the slot, so it does not show up as /dev/sdaX or /dev/mmcblk1p1 or as a source in the coreELEC system file manager GUI. The internal storage EMMC is showing up as /dev/mmcblk0pX but just can’t see the sd card in the slot.

I do not have this issue on the Radxa Zero original with 16GB EMMC storage. It will recognize the SD card in the onboard slot as expansion storage, and it shows up right away in the CoreELEC system → file manager gui.

If I try to install CoreELEC 20.2 to the sd-card and run it on that instead of the EMMC, it fails immediately on boot with error:

Starting debugging shell for boot step: mount_flash… type exit to quit
Error in mount_flash: mount_common: Could not mount UUID=3006-1615

@Portisch I can confirm the problems for Radxa Zero 2 when accessing an SD-Card using the boards slot. I can mount the SD-Card. However, I get many USB read/write errors even on a new card. Kernel log sys USB error -110. To my opinion this can be a problem with the Radxa2 kernel overlay file (timing issue?). I will re-install the system and try to generate a useable log.

1 Like

I tried the latest nightly 21.0 Omega beta1 build for the Radxa Zero 2 and the issue issue persists. I still cannot explore the SD card in the onboard slot, however if I use a USB OTG cable and USB SD card reader adapter, the storage opens in the CoreELEC system menu → File manager GUI right away.

Looks like the latest nightly build from December 19th I just tried may have addressed the issue. Awesome!