CoreELEC 20.5-Nexus Amlogic-ng Discussion


Please use this thread for general CoreELEC 20.5-Nexus Amlogic-ng discussion

Before posting an error please follow these troubleshooting steps.


20.5 still gets stuck loading HD media on my N2+'s. Same issue as 20.4

Rolled back to 20.3 and all is good.

Thanks for release
silly question perhaps : is CoreELEC 20.5-Nexus marked orange Pre-release (as opposed to green Latest) on purpose?

Yes, we wait until there are a certain number if updated devices and no major bugs to release it for auto update.

1 Like

OK … I will install on 4 different devices and will report any issues.

Hi, I noticed issue when install from repository - CE addon

I tried many times but the same problem. I hope you can fix this issue.

Hi, Is there any solution for this error in the screenshot above?

NG and NG-DV is already online. NE should be tomorrow.

1 Like

Is this CoreELEC-Amlogic-ne.aarch64-20.5-Nexus.tar update the previous version which has a bug in the Coreelec repository? Or if you would please provide me the stable for my device’s Dune hd homatics box?

No, you will just be patient until Amlogic-ne/20.5/aarch64/ get available:

Thank you for your clarify. I hope to get it soon.

I am seeing this but for the kodi repo…

I’m facing this matter with my Kodi skin, every startup the kodi this message pop up, when I tried to download this addon from Coreelec repository, kodi couldn’t connect to repository!

@Damas007: Should work now. Let us know if there is still issue and post kodi log in this case after fresh boot.

Thank you so much @vpeter worked.

1 Like

A post was merged into an existing topic: CoreELEC fail to fetch addon repository

Have you solved this ? Is is working for you at this moment ?