CoreELEC 21.0-Omega_alpha2 Amlogic-ng Discussion

Build from 02.07 works just fine

Update today to build from 16.07 and for now all is back to normal

Kodi Omega nightly development build “kodi-20230808-be5b014b-master-armeabi-v7a” for the first time play some P7 Fel movies on Ugoos AM6B Plus engaging both decoders, without issues. Just for information.
Thank you

Then yes, P7 FEL do play at least on Minix & Ugoos G12B DV with 4.9 kernel.
But seek is still broken.

Sorry cannot find “Amlogic-ng-dv.arm-20.3”
Where to find it?

When 20.3 is released


Thanks, waiting for it

I did manual build a nightly Amlogic-ng-dv.arm CoreELEC-20.3.
So you can test it on one of the two devices. FEL may work, may not, not sure.
When it works don’t try to seek! It’s for sure not working and you will need to stop/start the video again.

FEL does not work yet on Amlogic-ne.

It’s preferred to make a new install with this image instead update as it’s now Kodi Nexus and not Kodi Omega anymore:

Happy testing!


Thanks Portisch, downloading it now and soon after testing.

Congrats Portisch your build finally plays P7 Fel on the Ugoos AM6B plus. with "Convert Dolby Vision for compatibility set at Lossless.
Quickly tested more than 40 movies and, with 2 or 3 exceptions, all start to play without issue.
You and your devs have made a miracle.
So, waiting for any comment from users.
Thanks a lot again


Yes, I forgot to say you need to set it to lossless.

When I tested it, there is almost no problem to start playing, but the screen froze shortly after playback, resumed after a few seconds, and was skipped in between.For example: Fast X, Saving Private Ryan and John Wick 4.

Yes, this can happen with some movies. In my experience in many cases this depends on the remux. A very little syncro error between the 2 video tracks (BL and FEL) is causing this behaviour.

Thanks a lot for this test build :+1:
Have Ugoos AM6B+ here with CoreElec 19.5 (kernel 4.9.269) installed in DualBoot mode.
I can update online to CE 20.x versions via CoreELEC-20 update channel but this DV version is something extra (not there).
After 20.3 final release an option to migrate online to Amlogic-ng-dv.arm via CoreELEC-20 channel would be great help (if possible)…

Yesterday night I tested very quickly this build on many movies. Watched the movie was starting and then stop it and see the next one. Everything seemed ok as reported in my yesterday’s post.
Today I had more time to test and many movies after 3/4 minutes (more or less) start to freeze, stop and many times get a red screen. Very sad.
This is the situation actually.
Just to let you know.


Thanks for the DV nightly, just tried testing on my AM6B+. First FEL movie was Mortal Engines which played absolutely perfectly, I pressed stop at about 8 minutes to test some others.
Then I tried Jaws which unfortunately froze at about 4 minutes followed by a black screen. I didn’t get around to testing any others. But it looks like the same thing ragico already reported.
It’s great to be able to watch DV in CoreELEC thank you.

Edit: I did test a few other FEL files (I only have a few) and they either started freezing at 4 min or didn’t play well from the start.
Had a quick test with Android nightly and got mixed results but oddly Mortal Engines didn’t play that well on the Android nightly (some stuttering and ghosting), but none of that with the CE nightly. :slight_smile:

1 Like

With today official kodi development build " kodi-20230822-f5ab9fd5-master-armeabi-v7a.apk" 50% of my Fel collection plays without any major issue and many start playing and keep playing from the begininning. Just for your information.


My device is ugoos am6b plus 2021, and the system is corelec 21 alpha2 ng-dv. I have found two bugs so far: one is that the bluetooth remote needs to be re-paired after powering off the device, and the other is that the dolby vision is only working properly on some mp4 videos, and other mkv video formats are not playing properly.And, coreelec backup data cannot be restored.

The Dolby Vision version of corelec 20 ng-dv can also be activated, but it cannot be mapped normally

CoreELEC (official): 21.0-Omega_alpha2 (Amlogic-ng-dv.arm)
Machine model: UGOOS AM6B
CoreELEC dt-id: g12b_s922x_ugoos_am6b
Amlogic dt-id: g12b_AM6b_b4g

CoreELEC:~ # journalctl -l | paste
CoreELEC:~ # dmesg | paste
CoreELEC:~ # ce-debug
CoreELEC:~ # fw_printenv | paste

CoreELEC:~ # systemctl status opentee_linuxdriver.service -l --no-pager
● opentee_linuxdriver.service - Optee TEE-Supplicant and Video Firmware Preload service
     Loaded: loaded (/usr/lib/systemd/system/opentee_linuxdriver.service; disabled; preset: disabled)
     Active: active (exited) since Tue 2023-08-29 19:10:32 CST; 52min ago
   Main PID: 3303 (code=exited, status=0/SUCCESS)

Notice: journal has been rotated since unit was started, output may be incomplete.

corelec 21 alpha2 ng-dv isn’t recommended as it has issues. See…

You can downgrade to CoreELEC 20 Amlogic-ng-dv which is available to download on this thread. Post 19.
Also make sure you have DV set to lossless in corelec video settings.

Continue here:

1 Like