CoreELEC 21.0-Omega Amlogic-ng Discussion

Amlogic-ng

Please use this thread for general CoreELEC 21.0-Omega Amlogic-ng discussion

Before posting an error please follow these troubleshooting steps.

1 Like

I’m brand new to CE and I just got my AM6B+ yesterday and loaded up the last nightly and it works great, how do I get the build to show an update to 21 Stable? In the “Update Channel” I do not have an option for CoreELEC-21.

I suppose one can do usual upgrade from CE 20.5-Nexus by tar file in ~/.update right. Even when running from eMMC. Right? Or is complete reinstall needed?

sorry to reply to own question …

update: ng (and ne) update and add-on migration went well!

Thanks for the final release of v21.
One small note, at least in my case upgrading from rc2,
In system info->summary, version/build info is still saying running kodi-RC2

2 Likes

Do I need to perform a manual (clean) reinstall to go from 20.5 to 21? I don’t see an option in the updater.

Yes, looked like this build has an issue - v21 will be rebuild and uploaded again.

3 Likes

Just had an automatic update to Omega 21.0 on my Odroid N2+ and it has installed Omega 21.0 -alpha 1. Tried a manual install selecting Omega 21.0 from the listed options, and alpha 1 has been re-installed.

I also notice that since this update the AEON-Silvo skin is no longer shown in the Kodi Repository, although I had it installed prior to this update.

Do you have any “21.0-Omega” in the list? I only have a “21.0-Omeg” there.
Here: Broken Omega update

You’re right - the list shows “21.0-Omeg”, not “21.0-Omega”. Didn’t spot that.

Yep, I tried to update from RC2 to the latest stable using updates from Coreelec configuration and I got the alpha too. Something’s not right.

Based on some preliminary testing of Omega 21 on my AM6B+:

Two issues:
With WebDAV sources (e.g. IIS WebDAV hosted), I get a phantom file not found error, sometimes immediately after playing, stopping and resuming/playing anything else (the same title or something else). This appears to be affecting CoreELEC, but not upstream such as Kodi 21 for Android thus far. It appears it might be somehow losing WebDAV authentication info when it happens? When it happens, usually it requires at least a full reboot (not just restarting kodi).

With HTTP sources (e.g. Apache httpd hosted), Kodi itself no longer seems to be extracting video metadata (such as codec, HDR info, etc) on a library scan/update. This on the other hand, is also impacting Kodi 21 on Android, and appears to be an upstream issue.

Once it can playback however, things seem to be playing great. And surprisingly MUCH better than the nvidia shield: With the Android Kodi 21 official app from the playstore, which now stutters like crazy on full UHD remuxes (probably due to the higher bitrate). Another nail in the coffin for my Shield…

Does anyone else use Hulu? Amazon, Netflix, Disney+ and Paramount+ all work fine for me with Omega but Hulu just freezes.

I already have a Jellyfin server all configured but am in the process of setting up my new AM6b+ (very excited, thanks CE team!). I see a lot of talk about Plex and PM4K, etc. Any reasons why the Jellyfin add-on wouldn’t work? I read in some forums that Jellyfin uses HLS streams with that plugin instead of just pointing Kodi to the file, but idk enough to confirm if that’s true, or if it would even be a problem. Any thoughts?

I use the Jellyfin plugin and it works fine here. Just installed it following the instructions on their site.

1 Like

Yes! 21.0 Omeg. And 21.0 Omeg loads and installs 21.0 Omega_alpha1. The only thing that will help is a manual download of the tar file from the website. Copy this file to storage/.update and restart CoreELEC. Then it works with the update to 21.0 Omega.

There is a bug in all “old” builds before 21.0-Omega and show only 21.0-Omeg.
We modified it now on server side so the 21.0-Omeg point to a non existing file and do not update by random image in list.

Systems with new uploaded 21.0-Omega release (09042024) do not show 21.0-Omeg at all anymore.

If you use a version before 21.0-Omega it’s need to update once manual by place the update file in the update folder on the device and reboot.

More infos: coreelec:updates [CoreELEC Wiki]

1 Like

I flashed this build before it was removed from github and it’s not showing the dolby vision options in System, CoreELEC.

Then I flashed the nightly https://relkai.coreelec.org/Amlogic-ng/ce-21/CoreELEC-Amlogic-ng.arm-21.0-Omega_nightly_20240409-Generic.img.gz and I still don’t see the options.

Ugoos AMB6+

https://wiki.coreelec.org/coreelec:ce_support

Please explain further. I’m not sure how a log will help you determine where the problem lies when the option is missing from the GUI itself?

EDIT: I have flashed CoreELEC-Amlogic-ng.arm-21.0-Omega-Generic.img.gz and I am still missing the Dolby Vision options on AM6B+.

Should I use 21.0-Omega/CoreELEC-Amlogic-ng.arm-21.0-Omega.tar instead?

Bit confusing seems like lots of releases on github all with the same version number over last few days.

Should we all keep updating everytime there is another ‘21.0’ release?

Any chance you could start versioning these fix releases rather than have them all labelled ‘21.0’? Thanks for all the work/effort all the same.