CoreELEC 21.0-Omega_beta1 Amlogic-ng Discussion

upgraded to CE21 with the 31/10 nightly and can confirm MariaDB works as expected

1 Like

Can I use a saved backup config from 20.3 in this 21.0 application?

1 Like

:slight_smile: thankyou
OK, I tried that (as I always have done in the past)
Sadly when it reboots it returns to the as installed format. (minus any changes I may of made, files, settings etc)
That was the reason I asked, I though maybe 20 couldn’t be put over 21 even though it has always worked on older renditions in the past.
I will try another sd card to rule that out (H96x2)

EDIT: New SD card fixed… when in doubt , throw it out :slight_smile:

I’m having an issue with multichannel FLAC PCM 5.0 audio on my N2+ through my Sony AVR DN1060. When I play a 5.0 music track I’m getting only playback of FL/FC/FR channels. My RL and RR speakers are silent. A 5.1 music track plays correctly. I think it’s an ALSA channel mapping issue which also occurred in CE 19 and was corrected at the time. Unfortunately, I can’t check back far enough in the posts as the forum software has changed in the meantime and I’ve also changed user name.

5.0 music tracks (with no LFE channel) are common enough on jazz and classical SACD and DVD-A titles, so I have several of them in my library, although I only play them rarely. The error is present in CE 20 also, but I hadn’t noticed it until now!

The attached log shows the issue at timestamp 17:40:15 (5.0 mapping error) and 17:41:35 (5.1 mapped correctly).

A quick question related to this build
On Nexus, I used to copy skin.estuary folder from .kodi/addons and use it to create my own skin copy (modifying home.xml)
Since Omega, I can’t find the skin.estuary folder… Does anyone know where it is now?
Or is there a way to download it from Github? I couldn’t find where from

The reason I am looking for a coreelec one, so this way I don’t lose the coreelec menus etc.

Still on same old location as /usr/share/kodi/addons/skin.estuary.

1 Like

Anyone was able to install CoreELEC-Amlogic-ng-dv.arm-21.0-Omega_beta1-Generic.img.gz on Minix U22-XJ ?

I installed it on U22X-J (Non max) last week to test DV. Installed fine and can play DV profile 5 and 8, while 4 and 7 dont play as i get only black screen. (7 MEL play fine). CEC settings dont save and the options on the cec page is not arranged similar to 20.2.

It is strange, I also have the same model and this version fails to start. I described the problem in these two posts : 1 and 2. Thank you for this info, I will try to factory reset the device and install it again. Any tips you can share?

I actually have couple of U22X-J non max boxes. One of them with 006A and other with 008 and this installs fine on both the boxes. I suspect some firmware corruption on your box is preventing the install. Factory reset will be good first step like you said.

Anyone have this version? Amlogic-ng-dv.arm CoreELEC-20.3


After I did the clean install of Minix firmware this amlogic-ng beta 1 loads fine on my u22-xj.
Is ceemmc tool supposed to work on this version? I have tried to use it with no luck so far. This is the log:

CoreELEC:~ # ceemmc

Starting CoreELEC eMMC installation tool...

eMMC size: 0x000747c00000 [32GB]

No CoreELEC installation found on eMMC

Install in dual boot mode, CoreELEC and Android on eMMC
  Use CoreELEC data from
    [1] current used SD or USB device
    [2] existing backup on current used SD or USB device

Install in single boot mode, only CoreELEC on eMMC
  Use CoreELEC data from
    [3] current used SD or USB device
    [4] existing backup on current used SD or USB device

Please choose one option? [1/2/3/4]: 3

Free space of 'partition CE_FLASH': 512MB
Warning: Could not find 'dto' partition!
Could not find 'CE_STORAGE' partition!
Failed to read size of partition 'CE_STORAGE'!
Failed to create new partition table!

Tested 20.3 dv nightly on Minix u22X-J (non max). It perform similar (slightly better) and play P7 FEL but colors are incorrect (color saturation too high). P4 has same result as 21 Omega. CEC also works well on 20.3. I think the box now able to play P5 and P8 is a huge win. Its all possible because of your efforts. Brining dead box back to life. Thanks for your hard work!!

Hi, will the DV version work with Beeling GT King?
Which version should I install for DV:

The GT King doesn’t have the soc with DV support, so no.

1 Like

The issue is that the s922x does not support DV or that the gt king is not licensed?

To have DV support it should have S922X-J. It doesn’t, so the soc version that GT King uses doesn’t have DV support. It’s plain S922X, or S922X-H in the pro version.

Where can I get a copy of a 32bit and 64bit dovi.ko files?