CoreELEC 21.0-Omega_beta1 Amlogic-ng Discussion


Please use this thread for general CoreELEC 21.0-Omega_beta1 Amlogic-ng discussion

Before posting an error please follow these troubleshooting steps.

After updating to beta1 on the Odroid N2, the connection to MariaDB 10 fails. It still worked with alpha3.

The IP address ends up on a blacklist:

error <general>: Unable to open database: MyMusic83 [1129](Host '' is blocked because of many connection errors; unblock with 'mariadb-admin flush-hosts')

On windows and on Homatics R 4K Plus (21.0-Omega_nightly_20231020, Amlogic-ne.aarch64) the database connection ist working with the same advancedsettings.xml.

2023-10-22 13:14:40.234 T:2424     info <general>: MYSQL: Connected to version 10.5.8-MariaDB-log
2023-10-22 13:14:40.276 T:2424     info <general>: Running database version MyMusic83
2023-10-22 13:14:40.299 T:2424     info <general>: Running database version MyVideos122 (98.8 KB)

Something went wrong and now you need to manually unblock connection?

It’s definitely due to ng-beta1, because if I change the IP address and downgrade to alpha3 with onother NIC, then it works. However, this is not an option because alpha3 still uses MyMusic82 and the other speakers are all already on MyMusic83.

As soon as I update to beta1, the connection to MariaDB is no longer possible… not even if I downgrade to alpha3. Changing the IP address doesn’t help either. Once beta1 has ensured that the MAC address ends up on the blacklist, a downgrade no longer helps. I was able to understand it with an USB NIC: alpha3/working → beta1/not working → alpha3/NOT working.

mariadb-admin flush-hosts

does help an I can connect to the database with ng-alpha3 again

And what does mariadb server logs says? This is starting point to fix the issue.

Sorry, but my database runs as an app on a QNAP NAS and it is beyond my skills to access the corresponding logs.

Well, then you can’t really expect much help from here.

Someone who also uses mariadb server can tell if works from them or they also have same issue.

1 Like

Thank you anyway

It’s indeed a bug in 32-bit builds, fixed in upstream yesterday.

Issue report
Pull request

1 Like

I will wait patiently

Hello All,

I cannot boot any 21.0 alpha or beta (dolby vision version) on microsd card on my Minix U22-XJ.
Followed this guide: coreelec:minix [CoreELEC Wiki]

Version 20.0-Nexus works flawlessly on the same card.
All I can capture is this:

I hope you tried Amlogic-ng, not Amlogic-ne…
But you did not tell us such facts…

I have used


Device tree: g12b_s922x_minix_u22xj.dtb (renamed to dtb.img in the root as usual)

Ready install CE 21 omega beta 1 nightly 24/10, in the Dune homatics works fine. I have a few doubts about the white list, in previous CE I assign white list to all resolution in 1080p, not 4k. I do the same in this CE 21 beta but a 4k movie in Dolby Vision show me Dolby Vision in 1080p, I take off all the white list and show perfect in 4k and Dolby Vision…!! I don’t know why!

Another thing, I like to customize my skin, in previous CE I use arctic zephyr but I don’t know if there are something better right now.

Thanks a lot for your work an your support

Whitelist also all 4k resolutions.

Ok, thanks… I’ll test it.

I have N2 and looking to move from 20.3 to 21.
A bit confused with where I can find the latest - on Beta1 or CE-21 nightly (which shows Jul 16th date)?

also - does someone know if the PR that solved the connectivity issue to MariaDB that was reported here, is already included with the latest?

The fix should be in nightly.

But there is a version from July - 2023-07-16 - and the fix was added to Libreelec sources a week ago…

@Portisch that is what got me confused, as the Beta seems to be from the 24th and nightly from the 16th July
Unless I am missing something here…