CoreELEC 8.99.2

It’s available in video file information

Is there any difference between the format of H264 or H265? What solutions are there?

Nothing major, just LAN speed still drops if box is left on for long periods. Vega s95 Telos. Drops from 180 down to about 30 MBit/sec. Wired Gigabit LAN.

After 8 hours or so the dropoff happens.

The video Is h.264

So I went from LibreELEC to CoreELEC because I love the official support for my S905X Android box. But yesterday I had to go back to LE and here’s why:

I have two freshly burned SDcard. 1 with LE (9.0.0) and 1 with CE (tried and 8.99.2). Both SDCards have the final Kodi Leia build and have only one folder from my server added with, amongst others, a 4K BBC Earth (h265, HDR) episode and TVHeadend client with 4K satellite channels.

Now the problem: CoreELEC just doesn’t show video on the 4K BBS Earth episode or 4K satellite channel, only sound. My LG OLED TV just says “No signal”. When I reboot with the LibreELEC SDCard, BBC earth plays fine with both audio and video and also my 4K satellite channels output properly. But I do not prefer LE because they don’t have official support for my android box.

I also tried CE because I read that the output format for 4K changed with 8.99.2 but that makes no difference.

Am I the only one with this or is there some setting to fix this?

Looks like you may be suffering from LG OLED 65B8 No video HDR content [Solved Bad Quality HDMI Cable] it looks like its being worked on

I checked that thread and downloaded the image from it but it doesn’t fix it for me. Also, after more testing I found out it has only to do with 4k itself and not HDR specific. Actually I’ve been able to get my BBC earth 4K/HDR playing by whitelisting 3840 × 2160 @ 25Hz. But as soon as I stop the playback my screen get distorted.
For now LibreELEC 9.0.0 unfortunately is the only distro which plays all my files with correct video, including 4k and HDR. But it has two major drawbacks which is no official support and somehow it does not playback MP2 audio (from satellite TV).

So I hope this will get fixed some time.

EDIT: After some further study I now have my MKV files playing fine. For that I had to whitelist all the 4K resolutions. Still don’t understand why that is necessary only with CoreELEC. Anyway, my 4K live TV satellite channels still give audio without video. Video is visible in PiP preview but “No signal” as soon as it goes full screen.

indeed, I was wrong! Sadly… :frowning:
The problem of saccade is still there !

@IanPH we are still working on the HDMI driver to get it to a point where it works well for everybody, the LE kernel is inherently broken in other ways and they have no interest in trying to help users with it, instead leaving it to BayLibre in the hope that their mainline work will fix what they are unable to.

We are looking for people who are willing to test the changes so if you are interested then hit me up with a message.

Please fix it FAV button on coreelec for KI PRO with meson: 0x1f KEY_FAVORITES is not going on last build also

As I already wrote in the other topic, open a new thread for this issue, please.

kodi 18.1 rc1 is out:

1 Like

Has anybody trouble with that archive?
I’m download it some times into .update folder and every time getting error extracting failed on install process…

Must be something wrong with the downliad itself. I had no issue.

Sometimes a virusscanner can mess up a file download. Did you try re-downloading…?

1 Like

Maybe your /storage partition is out of free space.

1 Like

Ok. All thanks. Problem is gone.

I currently use a Tanix TX3 mini, I’ve just got a Odroid C2. Both devices are now running CoreELEC 8.99.2. The question is, can I use the Tanix Coreelc system backup in Odroid C2?

Yes, it’s the same image.

1 Like

With my beelink GT1 S912, everything works perfectly.
Only last problems:

  1. Jerks with subtitles
  2. Frame rate of the GUI that does not always reach 60fps.

Good job ! Thanks.

There can be several reasons why you have “jerks” ie subtitle stutter:
a) you don’t have dirtyregions set to 0 in advancedsettings.xml
b) you have a sintax error in advancedsettings.xml
c) you have incorrect file format for advancedsettings.xml
d) you placed your advancedsettings.xml in wrong folder
e) you did not reboot after making change to advancedsettings.xml

To try if my advancedsettings.xml works for you, download it from here
copy it to /storage/.kodi/userdata/ and reboot.

1 Like